Closed Bug 1704882 Opened 2 years ago Closed 2 years ago

Checkbox in modal dialogs (e.g. remove extension, content handling) shows a focus outline when the dialog is opened

Categories

(Toolkit :: Notifications and Alerts, defect, P1)

Desktop
macOS
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox87 --- unaffected
firefox88 --- unaffected
firefox89 --- verified
firefox90 --- verified

People

(Reporter: clara.guerrero, Assigned: mconley)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-modals] [priority:2a] [proton-uplift])

Attachments

(3 files)

Affected platforms:
Platforms: Mac OS11

Steps to reproduce

  1. Launch the Firefox browser.
  2. install any add-on (i.e. Privacy Badger)
  3. Right Click the Extension and Select Remove Extension from the Context menu.

Expected result
The Remove (Extension Name) from Firefox modal should be displayed according with the new Proton design.

Actual result
The "Report this extension to Mozilla" checkbox is highlighted by default , as if I had pressed tab key.

Has Regression Range: --- → no
Has STR: --- → yes
Whiteboard: [proton-modals]
Severity: -- → S3

I can also reproduce in the "Allow this site to open zoommtg link" modal.

Is this macOS-specific?

Flags: needinfo?(clara.guerrero)
OS: Unspecified → macOS
Hardware: Unspecified → Desktop
Summary: "Report this extension to Mozilla" checkbox is highlighted by default in the Remove extension modal → Checkbox in modal dialogs (e.g. remove extension, content handling) shows a focus outline when the dialog is opened

Hi Gijs ,

The focus outline appearing in the remove extension modal is macOS-specific.
However, comment 1 happens in every OS (ubuntu and win as well)
Let me know if you need additional information.
Best,
Clara

Flags: needinfo?(clara.guerrero)
Priority: -- → P2
Whiteboard: [proton-modals] → [proton-modals] [priority:2a]
Priority: P2 → P1
Blocks: 1706259
Assignee: nobody → bigiri

Bernard: fwiw, there was some prior discussion in https://bugzilla.mozilla.org/show_bug.cgi?id=1706259#c3 , as well as in https://phabricator.services.mozilla.com/D110483 , and so this may not be straightforward.

Assignee: bigiri → nobody

I'm not able to reproduce with the add-on removal case (comment 0) anymore on macOS. Are you, Clara?

Flags: needinfo?(clara.guerrero)

I can, however, reproduce with the permissionDialog.xhtml dialog on macOS.

Assignee: nobody → mconley
Status: NEW → ASSIGNED
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4b0e47de2e6b
Prevent focus ring when automatically moving focus to first focusable element in a SubDialog. r=Gijs
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Mike, could you request an uplift to beta as this is a p2a? Thanks

Flags: needinfo?(mconley)

Comment on attachment 9218461 [details]
Bug 1704882 - Prevent focus ring when automatically moving focus to first focusable element in a SubDialog. r?Gijs!

Beta/Release Uplift Approval Request

  • User impact if declined: Required for MR1 / Proton
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A simple, one-liner change that only affects subdialog focus rings.
  • String changes made/needed: None.
Flags: needinfo?(mconley)
Attachment #9218461 - Flags: approval-mozilla-beta?

Comment on attachment 9218461 [details]
Bug 1704882 - Prevent focus ring when automatically moving focus to first focusable element in a SubDialog. r?Gijs!

Approved for 89 beta 6, thanks.

Attachment #9218461 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Whiteboard: [proton-modals] [priority:2a] → [proton-modals] [priority:2a] [proton-uplift]

This issue is verified as fixed in our latest 89.0b7 and our latest Nightly build 90.0a1 (2021-05-04) on Mac 11.
Also tested the scenario from Comment 1 with the Zoom link and that issue no longer occurs either. I will update the flags.

Status: RESOLVED → VERIFIED
Flags: needinfo?(clara.guerrero)
You need to log in before you can comment on or make changes to this bug.