Closed Bug 1705379 Opened 8 months ago Closed 8 months ago

Lack of contrast on Light for the Address Bar mouse hovered results

Categories

(Firefox :: Address Bar, enhancement, P2)

enhancement

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mak, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-address-bar] [priority:2c])

The mouse hovered results use secondary background, that is #F0F0F4, while the background is white. On my decent IPS screen the difference is barely noticeable.
While rows take a huge amount of horizontal space so that is still somehow visible, now that bug 1702772 will uniform other entries, like Search shortcut buttons, the mouse hover feedback on those will be barely visible. There's just some padding around the engine icon barely changing color there.
I expect most people with worse screens or more sight problems than me (and I'm not the best sighted person in the world!) won't see any feedback at all.

Dark is in a better shape regarding Secondary contrast, how you can see on the Figma colors palette.

Amy, is there anything we can do about this? Would it be possible to tweak Light secondary a bit to increase visible feedback? (thus increase contrast against white)

Flags: needinfo?(amlee)
Summary: Lack of contrast on Light for the mouse hovered results → Lack of contrast on Light for the Address Bar mouse hovered results

(In reply to Marco Bonardo [:mak] from comment #0)

The mouse hovered results use secondary background, that is #F0F0F4, while the background is white. On my decent IPS screen the difference is barely noticeable.
While rows take a huge amount of horizontal space so that is still somehow visible, now that bug 1702772 will uniform other entries, like Search shortcut buttons, the mouse hover feedback on those will be barely visible. There's just some padding around the engine icon barely changing color there.
I expect most people with worse screens or more sight problems than me (and I'm not the best sighted person in the world!) won't see any feedback at all.

Dark is in a better shape regarding Secondary contrast, how you can see on the Figma colors palette.

Amy, is there anything we can do about this? Would it be possible to tweak Light secondary a bit to increase visible feedback? (thus increase contrast against white)

Hi,

Since we have 2 different hover states (mouse hover and tab hover) and also pressed states, it's difficult to tweak the one mouse hover without having to adjust the rest of the states to ensure there's enough contrast between those states. If the mouse hover is darker, there will be less contrast to the tab hover and also the pressed states. The most important aspect is that there is enough contrast between the URL text and the background and there is feedback when a user clicks on the URL (i.e takes you to the webpage). A hover state provides secondary support but we don't depend on it.

Flags: needinfo?(amlee)

But we were able to make it work before, no? Is the current palette not flexible enough? The fact that Google Calendar context menus also have a very low contrast ratio on mouse hover is already enough to disturb me greatly, let alone if the single most important navigational element in the browser starts doing that. And I'm not even an avid mouse user ;-)

I can imagine that this is going to cause us to be less usable for Windows users in particular, who we know are more avid mouse users. Visual feedback for lesser accurate (pointer) devices, like touch pads, is important, I'd wager.

Flags: needinfo?(amlee)
Priority: -- → P2
Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2c]
Severity: -- → S4

Hi - Removing Amy from the NI - PM will prioritize the bug and at that point we will assign an owner from the UX team.

Flags: needinfo?(amlee)

The problem went away for me, not sure how and why, I was seeing a different color that was VERY faint.
I'm closing this since I cannot reproduce anymore, and leaving contrast problems to bug 1705072.

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.