Closed Bug 1705556 Opened 3 years ago Closed 3 years ago

mediaDevices.getUserMedia returns incomplete audio

Categories

(Core :: WebRTC: Audio/Video, defect)

Firefox 87
defect

Tracking

()

RESOLVED DUPLICATE of bug 1696794
Tracking Status
firefox87 --- affected
firefox88 --- unaffected
firefox89 --- unaffected

People

(Reporter: arturo_uo, Unassigned)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

Navigate to this site https://mdn.github.io/web-dictaphone/

Click on record and try to record an audio of at least 10 seconds.

I have tried with some other demo sites that use the same api and the result is the same.

This site has the same problem: https://mido22.github.io/MediaRecorder-sample/

No errors are displayed in the browser console.

Actual results:

The result will be an audio of 2 or seconds only.

Expected results:

The audio should be complete

This issue seems to be reproducible only on Firefox 87.0 on Windows 10 x64, macOS 10.15 and on Ubuntu 20.04 x64 , I couldn't managed to reproduce it on Firefox 88.0b9 or on Firefox Nightly 89.0a1.

Severity: -- → S3
Status: UNCONFIRMED → NEW
Component: Untriaged → WebRTC: Audio/Video
Ever confirmed: true
Product: Firefox → Core
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.