form submittal returns improper page refresh

RESOLVED DUPLICATE of bug 138957

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 138957
16 years ago
16 years ago

People

(Reporter: ryan bobko, Assigned: Alexandru Savulov)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.1) Gecko/20020826

select "automobile finance" for product and "california" for state. put in
"92602" for the area code and submit...page refreshes with the zip code blanked.
Page should refresh with a list of adresses.

Reproducible: Always

Steps to Reproduce:
1.select "automobile finance" for product and "california" for state
2.ut in "92602" for the area code and submit
3.

Actual Results:  
page refreshes with the zip code blanked

Expected Results:  
refreshed page with address information
(Assignee)

Comment 1

16 years ago
confirming bug
Status: UNCONFIRMED → NEW
Ever confirmed: true
We're submitting the exact data the page asks us for to the page the form points
to.... problem is, the page points to the same page as it's on.  No IE on hand
to test how the HTML it gets differs....
(Reporter)

Comment 3

16 years ago
This page works correctly in Konqueror
(Assignee)

Comment 4

16 years ago
in IE the search results display on the top of the form in the same color (gray
i think) but the form is still there so what we missing is the results.

The form's HTML is fairily straigt forward except i don't know yet what the
javascript does (there are three scripts loaded and some inline js :

<form name="frmManaging" method="post"
 action="cs_contact_info_results.asp?page=pa"
 onsubmit="return verify(this);">
<input type="Hidden" name="txtPageLoadCounter">
<table cellpadding="0" cellspacing="1" border="0" width="520">
<tr>
<td width="18"><img src="../images/spacer.gif" width="18" height="10"></td>
<td width="250">									<span class="content">Product:</span><br>
<select name="ddProductType">
<option value=""></option>
<option value="L" >Automobile Lease</option>
<option value="R" selected>Automobile Finance</option>
<option value="W" >Marine</option>
<option value="M" >Motorcycles</option>
<option value="P" >Power Equipment</option>
</select>
</td>
<td width="250">
<span class="content">State:</span><br>
<select name="ddStates"
onchange="javascript:SubmitState(ddStates[ddStates.selectedIndex].value);">
<option></option>
<option value="CA"
 selected
>California</option>
</select>
<!-- removed the rest of the options -->
</td>
</tr>
<tr>
<td colspan="3"><img src="../images/spacer.gif" width="18" height="8"></td>
</tr>
<tr>
<td width="18"><img src="../images/spacer.gif" width="18" height="10"></td>
<td width="250">
<span class="content">Zip Code<br>
<input type="Text" name="txtZipcode" maxlength="5" size="9">
</span>
</td>
<td width="250" valign="bottom"><input type="Submit" name="btnSearch"
value="Submit"></td>
</tr>
</table>
</form>

(copy/pasted from IE)
Search Results

Payment/Payoff Address:
AMERICAN HONDA FINANCE CORP.
P.O. Box 79055
CITY OF INDUSTRY,  CA   91716-9055   
 

To find your Honda Financial Services payment address:
Using the dropdown menus below, indicate the type of vehicle or product you are
currently financing. 
Select the state where you originally bought or leased your Honda or Acura, and
click Submit.

Comment 5

16 years ago
*** Bug 168370 has been marked as a duplicate of this bug. ***

Comment 6

16 years ago
Created attachment 103018 [details]
minimised testcase

This test illustrates that the bug occurs because the input type submit is not
submitting a value when the form is submitted by javascript.

Comment 7

16 years ago
Dupe

*** This bug has been marked as a duplicate of 138957 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.