Last Comment Bug 170641 - "Find Next" button doesn't always respond to Enter
: "Find Next" button doesn't always respond to Enter
Status: VERIFIED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: Phoenix0.2
Assigned To: Blake Ross
: Asa Dotzler [:asa]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2002-09-24 21:13 PDT by Nathan Silva
Modified: 2002-10-01 00:26 PDT (History)
0 users
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Hitting Enter should activate the "Find Next" button (9.53 KB, image/png)
2002-09-25 16:21 PDT, Nathan Silva
no flags Details

Description Nathan Silva 2002-09-24 21:13:38 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20020924 Phoenix/0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.2b) Gecko/20020924 Phoenix/0.1

In the "Find in this Page" dialog the "Find Next" button is the default button,
but it doesn't respond to the Enter key if you tab to one of the check boxes.

Reproducible: Always

Steps to Reproduce:
1. Choose Edit ยป Find in This Page...
2. Type something in the "Find what:" box.
3. Tab to the "Wrap" checkbox.
4. Press Enter.

Actual Results:  
Nothing

Expected Results:  
Enter should have activated the "Find Next" button.
Comment 1 Asa Dotzler [:asa] 2002-09-25 16:09:41 PDT
unable to reproduce this. can you give me a page and a term to find where this
can be reliably reproduced. 
Comment 2 Nathan Silva 2002-09-25 16:21:14 PDT
Created attachment 100649 [details]
Hitting Enter should activate the "Find Next" button

This bug isn't specific to a particular web page. It has to do with the button
focus in the Find dialog. In this image, notice that the Wrap checkbox is the
active control, and that the "default" highlight is on the Find Next button.

If you hit Enter, it should behave as though you clicked Find Next. Instead,
hitting Enter does nothing.
Comment 3 Asa Dotzler [:asa] 2002-09-25 17:22:38 PDT
You are correct. Sorry for misunderstanding. Confirmed with today's Phoenix
build on RH null.  
Comment 4 Blake Ross 2002-09-27 19:30:10 PDT
Fixed.
Comment 5 Asa Dotzler [:asa] 2002-10-01 00:26:02 PDT
verified fixed. 

Note You need to log in before you can comment on or make changes to this bug.