Closed Bug 1706488 Opened 3 years ago Closed 3 years ago

Enable non-opaque compositor surface support

Categories

(Core :: Graphics: WebRender, task)

task

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: gw, Assigned: gw)

References

(Regressed 2 open bugs)

Details

(Keywords: perf-alert)

Attachments

(1 file)

No description provided.

This removes the code in Gecko that was only allowing opaque
compositor surfaces, now that the underlying work in WR and
SWGL to support these is complete.

Assignee: nobody → gwatson
Status: NEW → ASSIGNED

It's a little difficult to tell with the unrelated intermittents, but I think the only remaining test failures are in Win10 SW-WR (see R4 on Win10 in [1]).

It looks like those two canvas tests draw correctly in the test, but then the reference is a blank output and the text remains. Lee, any ideas what might cause that?

[1] https://treeherder.mozilla.org/jobs?repo=try&revision=6f108a823e71777a6f13c3aaebff287b0f4b1f41&selectedTaskRun=Oyh0uwLsTVCb4wFaU4jGAw.0

Flags: needinfo?(lsalzman)
Pushed by gwatson@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/2a384027ee9b
Enable non-opaque compositor surface support r=gfx-reviewers,lsalzman
Flags: needinfo?(lsalzman)
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Regressions: 1707329

== Change summary for alert #29806 (as of Sat, 24 Apr 2021 14:17:40 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
38% glterrain (docs) windows10-64-shippable-qr e10s stylo webrender-sw 2.20 -> 1.36
8% glterrain (docs) macosx1015-64-shippable-qr e10s stylo webrender-sw 3.75 -> 3.44
4% glterrain (docs) macosx1015-64-shippable-qr e10s stylo webrender 1.92 -> 1.84

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=29806

Regressions: 1720263
Regressions: 1721133
Regressions: 1723251
Regressions: 1731485
Regressions: 1733856
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: