repeat of html when using multiple <style> blocks

VERIFIED FIXED

Status

()

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: displague, Assigned: vidur)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [TESTCASE], URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
the menu (table) on the top of the page gets doubled because of the multiple
style sheet blocks.. also the "country list" button is not being centered.

Updated

19 years ago
Whiteboard: [TESTCASE]

Comment 1

19 years ago
I'm seeing this with build 1999102110 on Win95.

I'll only address the repeating html problem here. I have no idea what could be
causing it, but multiple <style> blocks aren't necessary, just having one in the
middle of the markup triggers this behaviour. It seems that everything up to the
last tag preceding the <style> block gets doubled, and that even a comment
counts.

I know that sounds odd, but I have a testcase that shows this..

Comment 2

19 years ago
Created attachment 2378 [details]
Reduced testcase
Assignee: peterl → rickg
Component: Style System → Parser
The content model is a little suspicious only in that the refcount on the first
text node is high (which I would guess is because there are two frames for that
text node).  I'm not sure what component that makes it, so moving to Parser...

html refcount=3<
  head type=text/css refcount=2<
    style type=text/css refcount=2<
      Text refcount=2<\r\nBODY { font-size: 14pt; }\r\n>
    >
  >
  body refcount=3<
    Text refcount=4<\n\nThis is doubled.\n\nSo is this.\n\n>
    Comment refcount=2<!-- this line is important. -->
    Text refcount=3<\n\nThis isn't doubled.\n\nNeither is this.\n\nNor
this.\n\n\n\n>
  >
>

Updated

19 years ago
Assignee: rickg → vidur
Component: Parser → Layout

Comment 4

19 years ago
Vidur -- this is not a parser problem after all. The issue is that we're getting
duplicate frames on content that preceeds the style element. I'm guessing that
it's the same old dbl-frame problem we had before. (Call me for a dump on the
problem if you don't already know it).
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Assignee)

Comment 5

19 years ago
This seems to work correctly now. I suspect this was last checked before my sink
changes.

Updated

19 years ago
Keywords: verifyme

Comment 6

19 years ago
[bugday]marking verified. the testcase works for me on winNT build 2000022908.
Status: RESOLVED → VERIFIED

Updated

10 years ago
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.