Closed Bug 1707949 Opened 7 months ago Closed 7 months ago

Update Urlbar icon colors to match toolbar icon colors

Categories

(Firefox :: Address Bar, task, P1)

task
Points:
1

Tracking

()

RESOLVED FIXED
90 Branch
Iteration:
90.1 - Apr 19 - May 2
Tracking Status
firefox89 + fixed
firefox90 --- fixed

People

(Reporter: harry, Assigned: harry)

References

(Blocks 1 open bug)

Details

(Keywords: perf-alert, Whiteboard: [proton-address-bar] [proton-uplift])

Attachments

(1 file)

UX points out that the icons in the address bar are lighter than the toolbar icons in light/default theme. The address bar icons appear to be pulling their color from the address bar text. They should be #5B5B66.

P1 since this is an icons-related bug.

Assignee: nobody → htwyford
Status: NEW → ASSIGNED
Iteration: --- → 90.1 - Apr 19 - May 2
Points: --- → 1

This patch introduces --urlbar-icon-fill rather than reuse --toolbarbutton-icon-fill because we don't want third-party themes to be able to style the Urlbar buttons (otherwise, they could obscure the lock/shield icons).

QA Whiteboard: [proton-address-bar]

(In reply to Harry Twyford [:harry] from comment #0)

UX points out that the icons in the address bar are lighter than the toolbar icons in light/default theme.

I think you meant to say the opposite, address bar icons are currently darker than toolbar icons, because that's what I see.
I actually thought the problem were the toolbar icons not being contrasted enough, good to know they are as intended.

Attachment #9218796 - Attachment description: Bug 1707949 - Update Urlbar icon colors to match toolbar icon colors. r?mak! → Bug 1707949 - Update Urlbar icon opacity to match toolbar icon colors. r?mak!

[Tracking Requested - why for this release]:
Proton icon colours.

I'll request uplift tomorrow, after I verify the fix in Nightly.

Flags: needinfo?(htwyford)
Pushed by htwyford@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/eff327b57d72
Update Urlbar icon opacity to match toolbar icon colors. r=mak,desktop-theme-reviewers,dao
Status: ASSIGNED → RESOLVED
Closed: 7 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9218796 [details]
Bug 1707949 - Update Urlbar icon opacity to match toolbar icon colors. r?mak!

Beta/Release Uplift Approval Request

  • User impact if declined: Proton color inconsistency.
  • Is this code covered by automated tests?: No
  • Has the fix been verified in Nightly?: Yes
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Small changes to CSS and theme manifests.
  • String changes made/needed:
Flags: needinfo?(htwyford)
Attachment #9218796 - Flags: approval-mozilla-beta?
QA Whiteboard: [proton-address-bar] → [proton-address-bar] [proton-uplift]
QA Whiteboard: [proton-address-bar] [proton-uplift]
Whiteboard: [proton-address-bar] [proton-uplift]

Comment on attachment 9218796 [details]
Bug 1707949 - Update Urlbar icon opacity to match toolbar icon colors. r?mak!

Approved for 89 beta 7, thanks.

Attachment #9218796 - Flags: approval-mozilla-beta? → approval-mozilla-beta+

== Change summary for alert #29967 (as of Wed, 05 May 2021 05:44:02 GMT) ==

Improvements:

Ratio Suite Test Platform Options Absolute values (old vs new)
18% youtube SpeedIndex windows10-64-shippable-qr warm webrender 983.75 -> 803.92
18% youtube SpeedIndex windows10-64-shippable-qr warm webrender 983.50 -> 806.50
6% google-docs ContentfulSpeedIndex macosx1014-64-shippable-qr warm webrender 459.33 -> 432.17
5% youtube FirstVisualChange android-hw-g5-7-0-arm7-api-16-shippable-qr warm webrender 285.42 -> 270.42

For up to date results, see: https://treeherder.mozilla.org/perfherder/alerts?id=29967

Keywords: perf-alert

You basically fixed bug 1704795 (https://bugzilla.mozilla.org/show_bug.cgi?id=1704795#c2) changing icons opacity, and this is a clear indication we can't do nothing about that bug, this test is just over-reacting to simple chrome changes.

You need to log in before you can comment on or make changes to this bug.