Closed Bug 1708488 Opened 5 months ago Closed 5 months ago

Initialize NSS in preallocated processes, before RecvConstructBrowser

Categories

(Core :: DOM: Content Processes, task, P3)

task

Tracking

()

RESOLVED FIXED
90 Branch
Fission Milestone M8
Tracking Status
firefox90 --- fixed

People

(Reporter: jesup, Assigned: sefeng)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fission-perf][qf:p2:responsiveness])

Attachments

(1 file)

We noticed in https://share.firefox.dev/2Pzksf3 that NSS seemed to be inited in newly allocated Content processes; we could probably init it in the preallocation phase and drop a little overhead.

Depends on: 1708490

We want to avoid loading NSS in content processes because, IIUC, we shouldn't need to read certs in content process. That is bug 1566191.

But tracking this bug for Fission M8 as a fallback option in case fixing bug 1566191 is more work than expected.

Severity: -- → N/A
Type: defect → task
Fission Milestone: ? → M8
Priority: -- → P3
See Also: → 1566191
Severity: N/A → S3
Whiteboard: [fission-perf][qf] → [fission-perf][qf:p2:responsiveness]
Assignee: nobody → sefeng
Pushed by sefeng@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/efda854f119f
Initialize NSS earlier in preallocated processes for fisson r=jesup,keeler
Status: NEW → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Blocks: 1711043
Regressions: 1711223
You need to log in before you can comment on or make changes to this bug.