Closed Bug 1708596 Opened 1 year ago Closed 1 year ago

Excessive flickering in the Today Pane

Categories

(Calendar :: Calendar Frontend, defect)

defect

Tracking

(thunderbird_esr78 wontfix, thunderbird89 fixed)

RESOLVED FIXED
90 Branch
Tracking Status
thunderbird_esr78 --- wontfix
thunderbird89 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

(Keywords: perf)

Attachments

(1 file)

When just about anything happens in the calendar, the Today Pane agenda view refreshes everything, even calendars unrelated to what happened. I made this worse with bug 1691885 but also made it slightly easier to fix with bug 1700047. In this bug I'm going to try to restrict refreshing to only those calendars that need it.

With this patch, we only refresh the calendar that changed.

I've also renamed some functions from 'deleteFoo' to 'removeFoo' as that's a more appropriate verb. And I've removed a redundant update when a calendar colour changes, as that's now handled elsewhere.

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/367a5b568b23
In the Today Pane, refresh only calendars that require refreshing. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9219767 [details]
Bug 1708596 - In the Today Pane, refresh only calendars that require refreshing. r?mkmelin

[Approval Request Comment]
Regression caused by (bug #): bug 1691885, sort of
User impact if declined: Today Pane reloads everything any time an event changes
Testing completed (on c-c, etc.): just landed, I'd want it in Daily for at least a week just in case, so targeting beta 4?
Risk to taking this patch (and alternatives if risky): a small possibility there are edge cases I've missed, but they should only result in bad display of data that can be corrected

Attachment #9219767 - Flags: approval-comm-beta?

Is 78 unaffected?

Yes. Actually no, it is affected, but it's much worse on beta. I don't intend to uplift this to 78.

Thanks for the assessment

Severity: -- → S3
Keywords: perf

Comment on attachment 9219767 [details]
Bug 1708596 - In the Today Pane, refresh only calendars that require refreshing. r?mkmelin

[Triage Comment]
Approved for beta

Attachment #9219767 - Flags: approval-comm-beta? → approval-comm-beta+
Regressed by: 1691885
See Also: → 1700047
You need to log in before you can comment on or make changes to this bug.