Closed Bug 1709106 Opened 5 months ago Closed 5 months ago

"You are securely connected to this site" overlaps the lock icon in Nightly

Categories

(Firefox :: Site Identity, defect, P1)

Firefox 90
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox88 --- unaffected
firefox89 --- unaffected
firefox90 + verified

People

(Reporter: mconley, Assigned: asahai100)

References

(Regression)

Details

(Keywords: regression)

Attachments

(4 files)

Attached image image.png

See screenshot.

Looking for regression range.

Duplicate of this bug: 1709100
Regressed by: 1575080
No longer blocks: proton-door-hangers
Whiteboard: [proton-door-hangers]

Hi Anshul! Do you think you'd have time to look at this?

Flags: needinfo?(asahai100)
Version: unspecified → Firefox 90
Severity: -- → S3
Priority: -- → P2
Priority: P2 → P1

(In reply to Mike Conley (:mconley) (:⚙️) (Catching up on needinfos) from comment #2)

Hi Anshul! Do you think you'd have time to look at this?

Hi!
Sure, I can look into this.
I'm able to reproduce this on my nightly[90.0a1 (2021-05-04) (64-bit)], system is Linux Ubuntu.
Let me try resolving this.

Flags: needinfo?(asahai100) → needinfo?(mconley)
Attached video Overlapping_Issue.mov

fyi: I've reported the duplicate bug 1709100 for macOS. And I am still seeing it in Nightly 90.0a1 (2021-05-03) (64-Bit). A screenrecording is attached. Thanks.

Okay, thank you. Adding for 90 tracking just so that we don't lose track of this.

[Tracking Requested - why for this release]:

This is a pretty obvious visual glitch in one of our primary panels.

Flags: needinfo?(mconley)
Attached image Screenshot

This issue occurs not only secure connection but also insecure connection.
See screenshot.

Duplicate of this bug: 1709680
Duplicate of this bug: 1709431

Hi Anshul,

Any headway with this? I suggest if this doesn't look straight-forward, that we back out the regressor (bug 1575080) in the next day or so.

Flags: needinfo?(asahai100)
Duplicate of this bug: 1709525
Assignee: nobody → asahai100
Status: NEW → ASSIGNED

Hey Mike!
Do you think this solves the issue? As much as I can tell, this solves it and doesn't override any other feature. What do you think?

Flags: needinfo?(asahai100)
Flags: needinfo?(mconley)

Thanks! Reviewed - I think I have a question for pbz about the security-view class: https://phabricator.services.mozilla.com/D114470#3718070

Flags: needinfo?(mconley) → needinfo?(pbz)

See inline reply

Flags: needinfo?(pbz)
Duplicate of this bug: 1709991
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8dba7c93da55
Making changes so that "You are securely connected to this site" doesn't overlap the lock icon. r=mconley
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
Duplicate of this bug: 1710026
Duplicate of this bug: 1710189
Flags: qe-verify+

I have reproduced the issue on an affected Nightly build 90.0a1 (2021-05-03)
The fix was verified on 90.0b2 (2021-06-01). Tests were performed on Ubuntu 20.04, Windows 10 and macOS 10.15. Thanks!

Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.