Closed Bug 1709476 Opened 1 year ago Closed 1 year ago

Allow falling back to Software WebRender with a GPU process in late beta/release

Categories

(Core :: Graphics: WebRender, task, P2)

Desktop
Windows
task

Tracking

()

RESOLVED FIXED
90 Branch
Tracking Status
firefox89 --- fixed
firefox90 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

Details

Attachments

(1 file)

In order to pick up more Software WebRender users, we should:

  1. We should allow falling back to Software WebRender with a GPU process in late beta/release on Windows, from WebRender and D3D11.

  2. We should allow falling back to Software WebRender without a GPU process in late beta/release on Linux, from WebRender.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7b6b315837d9
Allow falling back to Software WebRender from D3D11/WebRender in release. r=jrmuizel
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9220221 [details]
Bug 1709476 - Allow falling back to Software WebRender from D3D11/WebRender in release.

Beta/Release Uplift Approval Request

  • User impact if declined: Fewer users will get Software WebRender in 89 late beta and release than desired.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No; I manually verified via a try build with a release configuration. It can only be verified in late beta and release configurations.
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): A common reason many users get Basic compositing in release is because we tried D3D11 compositing and failed. This patch allows users to fallback from D3D11 to Software WebRender instead. We are already shipping Software WebRender to users in release, and would like to expand our population to include more users.
  • String changes made/needed:
Attachment #9220221 - Flags: approval-mozilla-beta?

Comment on attachment 9220221 [details]
Bug 1709476 - Allow falling back to Software WebRender from D3D11/WebRender in release.

Having more users on Software WebRender is good, let's take this patch in 89 beta 10, thanks.

Attachment #9220221 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
You need to log in before you can comment on or make changes to this bug.