Closed Bug 170949 Opened 19 years ago Closed 19 years ago

Parser fails to read certain comment string

Categories

(Core :: DOM: HTML Parser, defect)

x86
Linux
defect
Not set
major

Tracking

()

VERIFIED DUPLICATE of bug 101600

People

(Reporter: jo.sender, Assigned: harishd)

References

()

Details

Mozilla 1.1(Mozilla/5.0 (X11; U; Linux i686; de-AT; rv:1.1) Gecko/20020826). and
Netscape 7.0 (Mozilla/5.0 (Windows; U; Win-NT; de-DE; rv:1.0.1) Gecko/20020826)
both fail to interpret correctly following pages:

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//DE">
<HTML>
<HEAD>
<TITLE>Parser Test</TITLE>
</HEAD>
<!-- -------------- test -->
<BODY>
SIC<BR>
</BODY>
</HTML>

or

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2 Final//DE">
<HTML>
<HEAD>
<TITLE>Parser Test</TITLE>
</HEAD>
<!-- test -- -->
<BODY>
SIC<BR>
</BODY>
</HTML>

The malefunctioning is caused by the comment string in above code. Comment end
is not recognized correctly. 
There are lots of other "-" combinations that cause the same error.

Above URL shows the page where error was first seen. (Mathematical fomulary; german)
Is this a valid DOCTYPE?
I thought only "... Final//EN" exists?

Everything works fine when I change "Final//DE" to "Final//EN".
dupe of bug 101600?
Duplicate of bug 106100 is probably the best resolution. In strict
mode, we follow the CORRECT HTML parsing specification, where <! and 
> represent the beginning and end of a markup declaration, and -- is 
the comment delimiter: <!-- this is in a comment -- this is in a 
markup declaration but not in a comment -- this is in a comment 
again -->

Quirks mode uses "<!--" and "-->" as comment delimiters, but you 
should NOT use the string "--" within a comment.

*** This bug has been marked as a duplicate of 101600 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
vrfy dup -
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.