Open Bug 1709656 Opened 7 months ago Updated 7 months ago

The Data Policy infobar should not have an icon

Categories

(Firefox :: Messaging System, defect, P2)

Desktop
All
defect

Tracking

()

Tracking Status
firefox-esr78 --- disabled
firefox88 --- disabled
firefox89 --- affected
firefox90 --- affected

People

(Reporter: danibodea, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-infobars] [priority:2c])

Note

  • When the user triggers the Data Policy infobar (starts a firefox profile for the first time without an internet connection), he will notice that the newly designed infobar has an icon when it shouldn't. "FIrefox Informational" infobars should not show any icon as opposed to the "(just) Informational" type ones that should have the blue encircled "i" icon.

Affected versions

  • Nightly v90.0a1
  • Beta v89.0b8
  • Beta v89.0b7
  • Beta v89.0b5
  • Beta v89.0b3
  • Beta v89.0b1

Affected platforms

  • all

Steps to reproduce

  1. Disable the internet connection (easily by pulling the network cable out of the PC)
  2. Open a new profile.
  3. Notice that Data policy infobar.

Expected result

  • It has no icon.

Actual result

  • The encircled 'i' icon is being displayed incorrectly.

Regression range

  • Not a regression, but an implementation issue.
  • An exact change pushlog could not be provided because mozregression could not be used to investigate it considering the need to start a fresh profile without an internet connection.

Additional notes

Blocks: 1693758
Whiteboard: [proton-infobars]
Priority: -- → P2
Whiteboard: [proton-infobars] → [proton-infobars] [priority:2c]
You need to log in before you can comment on or make changes to this bug.