Closed Bug 1710796 Opened 9 months ago Closed 8 months ago

DisableAppUpdate still prompts update when typing in url box

Categories

(Firefox :: Enterprise Policies, defect, P2)

Firefox 87
defect

Tracking

()

VERIFIED FIXED
90 Branch
Tracking Status
firefox-esr78 --- verified
firefox90 --- verified
firefox91 --- verified

People

(Reporter: thisbemylogin, Assigned: mkaply)

Details

Attachments

(3 files)

Attached image about:policies (Active)

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:87.0) Gecko/20100101 Firefox/87.0

Steps to reproduce:

I have "DisableAppUpdate": true set in policies.json on Firefox 87.0, Firefox Portable Edition.

I started typing in the url box, "set firefox tab", and I get a prompt to download the latest Firefox.

Actual results:

I started typing in the url box, "set firefox tab", and I get a prompt to download the latest Firefox.

Expected results:

I should not get a prompt to download the latest Firefox.

Attached image the actual error
Attachment #9221513 - Attachment description: error 02.png → about:policies (Active)

To clarify, this is Firefox 87.0 "Portable Edition" from https://portableapps.com/news/2021-03-23--firefox-portable-87.0-released

I do not think that is affecting the error, as in the About Firefox window I am getting the "updates are disabled" message and all of my policies seem to be working. I did search for "DisableAppUpdate" before posting this bug but didn't see it listed.

Thanks for your work on Firefox, it's deeply appreciated!

The Bugbug bot thinks this bug should belong to the 'Firefox::Enterprise Policies' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Enterprise Policies

Thanks for the report.

I think I know what to do for this.

WE should be checking if app update is disabled here

https://searchfox.org/mozilla-central/source/browser/components/urlbar/UrlbarProviderInterventions.jsm#516

Are these the default settings for portable Firefox?

Why are you disabling telemetry?

Severity: -- → S2
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P2
Assignee: nobody → mozilla
Status: NEW → ASSIGNED

No, these settings are not default for Firefox Portable.

As far as telemetry being off goes, I was just testing the option when I ran into this bug and hadn't reenabled it yet. Sometimes we push updates to the machines in order to cut back on as much superfluous network traffic as possible when working on the network. Like how DisableSystemAddonUpdate is enabled even though that's the default, I was filling the policies file with the options we may want to change for certain occasions so we can simply edit the file in the future instead of also needing to add to it.

Thanks for letting me know. FYI, this patch is going in and should be in Firefox 90.

Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/e753adfbdc7d
Don't show URL bar update hints if update is disabled. r=emalysz,mhowell

Backed out for failures on browser_policy_disable_app_update.js

backout: https://hg.mozilla.org/integration/autoland/rev/2be650765378c5b2244fe464d87e5464753b21b2

push: https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&revision=e753adfbdc7dced2b53544665c34dc92f53b7d89&selectedTaskRun=fFECCyIATymSE76jKL1_KA.0

tier 1 failure appear on a subsequent push: https://treeherder.mozilla.org/jobs?repo=autoland&group_state=expanded&selectedTaskRun=MTNpo8oJQ3GH3oMHPOqZNw.0&revision=f50820278a98553b80954165cee19ae9f42e9f02&searchStr=linux%2C18.04%2Cx64%2Ctsan%2Copt%2Cmochitests%2Ctest-linux1804-64-tsan%2Fopt-mochitest-browser-chrome-e10s%2Cbc15

failure log: https://treeherder.mozilla.org/logviewer?job_id=340351219&repo=autoland&lineNumber=3114

[task 2021-05-20T18:35:52.676Z] 18:35:52 INFO - TEST-PASS | browser/components/enterprisepolicies/tests/browser/disable_app_update/browser_policy_disable_app_update.js | The About Dialog panel Id should equal policyDisabled -
[task 2021-05-20T18:35:52.676Z] 18:35:52 INFO - Leaving test bound test_update_about_ui
[task 2021-05-20T18:35:52.676Z] 18:35:52 INFO - Entering test bound test_no_update_intervention
[task 2021-05-20T18:35:52.676Z] 18:35:52 INFO - Buffered messages finished
[task 2021-05-20T18:35:52.679Z] 18:35:52 INFO - TEST-UNEXPECTED-FAIL | browser/components/enterprisepolicies/tests/browser/disable_app_update/browser_policy_disable_app_update.js | Test timed out -
[task 2021-05-20T18:35:52.680Z] 18:35:52 INFO - GECKO(3828) | MEMORY STAT | vsize 3274MB | residentFast 447MB | heapAllocated 193MB
[task 2021-05-20T18:35:52.681Z] 18:35:52 INFO - TEST-OK | browser/components/enterprisepolicies/tests/browser/disable_app_update/browser_policy_disable_app_update.js | took 45015ms

Flags: needinfo?(mozilla)
Duplicate of this bug: 1712517
Pushed by mozilla@kaply.com:
https://hg.mozilla.org/integration/autoland/rev/df6f4591aeb9
Don't show URL bar update hints if update is disabled. r=emalysz,mhowell
Status: ASSIGNED → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch

Comment on attachment 9222216 [details]
Bug 1710796 - Don't show URL bar update hints if update is disabled. r?emalysz!

ESR Uplift Approval Request

  • If this is not a sec:{high,crit} bug, please state case for ESR consideration: Specifically related to enterprise (blocking updates)
  • User impact if declined: We show an update message when the user can't update
  • Fix Landed on Version: 90
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): Has test, only happens with policy.

This did cause an intermittent with TV on Linux. In talking to the search team, URLbar popups on Linux are known culprits for TV and we have no good solution.

  • String or UUID changes made by this patch:
Flags: needinfo?(mozilla)
Attachment #9222216 - Flags: approval-mozilla-esr78?

Comment on attachment 9222216 [details]
Bug 1710796 - Don't show URL bar update hints if update is disabled. r?emalysz!

Approved for 78.12esr.

Attachment #9222216 - Flags: approval-mozilla-esr78? → approval-mozilla-esr78+
Flags: qe-verify+
QA Whiteboard: [qa-triaged]

Hello I have managed to reproduce the issue with firefox 90.0a1(2021-05-04) on Windows 10, I can confirm that the issue is fixed 91.0a1(2021-06-24), 90.0, 90.0b10 (64-bit) and 78.12.0esr on Windows and Ubuntu. I will update the flags accordingly.

Thank you!

Status: RESOLVED → VERIFIED
QA Whiteboard: [qa-triaged]
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.