Closed Bug 1710935 Opened 1 year ago Closed 1 year ago

"WebDriver:NewSession" doesn't return empty proxy capability

Categories

(Testing :: Marionette, defect, P3)

Default
defect

Tracking

(firefox90 fixed)

RESOLVED FIXED
90 Branch
Tracking Status
firefox90 --- fixed

People

(Reporter: whimboo, Assigned: whimboo)

Details

Attachments

(1 file)

As noticed by Julian in the review of bug 1703805 there are some proxy related webdriver tests in new_session/response.py marked as failing:

https://searchfox.org/mozilla-central/source/testing/web-platform/meta/webdriver/tests/new_session/response.py.ini

I inappropriately tagged them as being caused by bug 1703805, which is wrong.

The underlying reason here is that we do not return the default proxy capability due to optimizing away an empty object:

https://searchfox.org/mozilla-central/rev/e3c34d34cc7dce56df377f05183ad379ac1de123/testing/marionette/session.js#749-753

To get this fixed we will have to do it similarly as for timeouts:

https://searchfox.org/mozilla-central/rev/e3c34d34cc7dce56df377f05183ad379ac1de123/testing/marionette/session.js#576

Pushed by hskupin@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/0cc6b9d31a1d
[marionette] Always return proxy capabilities for WebDriver:NewSession. r=marionette-reviewers,webdriver-reviewers,jdescottes

There is some kind of bug in the marshal() implementation that results in problems when passing through the proxy instance. To be in-par with timeouts it's enough to just set an empty object for the proxy capability for now.

Flags: needinfo?(hskupin)
Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 90 Branch
You need to log in before you can comment on or make changes to this bug.