Closed Bug 1711231 Opened 7 months ago Closed 6 months ago

Proton: Ubuntu suggestion keyboard hovering has a different color

Categories

(Firefox :: Address Bar, defect, P2)

Desktop
Linux
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox88 --- disabled
firefox89 --- affected
firefox90 --- affected

People

(Reporter: pablo.muir, Unassigned)

References

(Blocks 2 open bugs)

Details

(Whiteboard: [proton-address-bar] [priority:2c])

Attachments

(1 file)

Attached image pastel.png

Affected
Ubuntu 20 64bit

not affected
WIndows10, MacOS 10.15

Affected versions
Firefox nightly 90.0a1
Firefox beta 89.0b12

Preconditions
install theme https://addons.mozilla.org/es/firefox/addon/purple-pastel-cloud-aesthetic/
Proton ON

Steps to reproduce
Launch Firefox and set the theme from precondition
Click on search bar and type anything press the down keyboard key

Actual result
the color for keyboard hovering is blue

expected result
on release, the default ubuntu color for that is orange.

Note :

Noticed this on other themes too, its not the only theme affected

Mac: There is no issue since on release the color is blue
Windows: There is no issue since on release the color is blue(kind of a more pastel blue tho)
Ubuntu: Affected

Hi romain, could you please set a priority for bug?
thanks!

Severity: -- → S4
Flags: needinfo?(rtestard)
Whiteboard: [proton-address-bar]
Flags: needinfo?(rtestard)
Priority: -- → P2
Whiteboard: [proton-address-bar] → [proton-address-bar] [priority:2b]
Whiteboard: [proton-address-bar] [priority:2b] → [proton-address-bar] [priority:2c]

I seem to remember a bug where this was changed on purpose, and iirc Harry was involved in the discussion. Any idea?

Flags: needinfo?(htwyford)

(In reply to Pablo from comment #0)

expected result
on release, the default ubuntu color for that is orange.

We only use the system highlight color when the System theme is applied. Third party themes can set their own keyboard selection color with the popup_highlight property. For themes that do not define popup_highlight, we use a blue fallback on all platforms. This is so theme authors can expect consistent behaviour across platforms rather than thinking about whether their theme matches all possible system colors. Review discussion here.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(htwyford)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.