Closed Bug 1711439 Opened 4 months ago Closed 2 months ago

Crash in [@ CStdMarshal::MarshalObjRefImpl]

Categories

(Core :: Disability Access APIs, defect)

Unspecified
Windows 10
defect

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- wontfix
firefox91 --- fixed

People

(Reporter: gsvelto, Unassigned)

References

(Regression)

Details

(Keywords: crash, regression)

Crash Data

Crash report: https://crash-stats.mozilla.org/report/index/fcbcc5fa-3772-427f-854a-1dde70210516

Reason: EXCEPTION_ACCESS_VIOLATION_READ

Top 10 frames of crashing thread:

0 combase.dll CStdMarshal::MarshalObjRefImpl onecore\com\combase\dcomrem\marshal.cxx:1295
1 combase.dll CStdMarshal::MarshalObjRef onecore\com\combase\dcomrem\marshal.cxx:1178
2 combase.dll CStdMarshal::MarshalInterface onecore\com\combase\dcomrem\marshal.cxx:1118
3 xul.dll mozilla::mscom::FastMarshaler::MarshalInterface ipc/mscom/FastMarshaler.cpp:131
4 xul.dll mozilla::mscom::Interceptor::MarshalInterface ipc/mscom/Interceptor.cpp:349
5 combase.dll CDestObjectWrapper::MarshalInterface onecore\com\combase\dcomrem\coapi.cxx:821
6 combase.dll CoMarshalInterface onecore\com\combase\dcomrem\coapi.cxx:1160
7 combase.dll Ndr64ExtInterfacePointerMarshall onecore\com\combase\ndr\ndrole64\oleaux64.cxx:305
8 rpcrt4.dll void Ndr64TopLevelPointerMarshall 
9 rpcrt4.dll void Ndr64TopLevelPointerMarshall 

This crash is happening fully within Windows code for users that have accessibility enabled. I'm unsure what might be causing it, maybe the correlations will give some clue. Filing this even though it might not be our fault so that we can track the volume.

Severity: -- → S3

This looks fairly frequent on beta 90. We might want to revisit the severity?

Looks like this was also fixed by bug 1716549.

Status: NEW → RESOLVED
Closed: 2 months ago
Depends on: 1716549
Flags: needinfo?(jteh)
Regressed by: 1694865
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
You need to log in before you can comment on or make changes to this bug.