Closed Bug 1712817 Opened 6 months ago Closed 4 months ago

Improve the header file logic in ./mach vendor

Categories

(Developer Infrastructure :: Mach Vendor & Updatebot, defect, P3)

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: tjr, Assigned: tjr)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

If you take a May 25 2021 checkout of m-c (e.g. 0c8d79edfc9a27b8eab7a71c7addeb223845275f ) and try to update libdav1d to a revision as of that date (e.g. c54add020492e3cca0da5ab90fa69c92ba496384) it will add ../../../third_party/dav1d/src/arm/asm-offsets.h to SOURCES. It should go into EXPORTS.

We should detect if a file added is a header instead of a source file, and if so only consider adding it to EXPORTS rather than SOURCES.

Priority: -- → P3
Assignee: nobody → tom
Status: NEW → ASSIGNED
Pushed by tritter@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d04e9ef5a778
Support adding header files to EXPORTS in mozbuild rewriting r=jewilde
https://hg.mozilla.org/integration/autoland/rev/292e32e520c1
Add tests for mozbuild file editing r=jewilde
Pushed by tritter@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/752e9fe54b3f
Support adding header files to EXPORTS in mozbuild rewriting r=jewilde
https://hg.mozilla.org/integration/autoland/rev/d4b681a741bd
Add tests for mozbuild file editing r=jewilde
Pushed by imoraru@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/182ae38519ef
fix black lint failures. a=lint-fix CLOSED TREE

The tests are failing because I am now more relying on ast_get_source_segment in the test and it is failing because while I copy/pasted the function from python 3.8 into 3.7 it has probably been silently failing because end_lindno is not present in Python 3.7

I might be back to trying to get Python 3.8 into the Updatebot Docker image. That would make sure Updatebot works better but not solve the problem for the tests which will run on the normal build machines which are 3.7

We should detect if a file added is a header instead of a source file, and if so only consider adding it to EXPORTS rather than SOURCES.

Actually... we shouldn't blindly add things to EXPORTS. EXPORTS is an unnecessary step in most cases. In most cases, the few places that need the headers would add a LOCAL_INCLUDES.

Pushed by tritter@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/4dbaf9a28c11
Support adding header files to EXPORTS in mozbuild rewriting r=jewilde
https://hg.mozilla.org/integration/autoland/rev/a1b4ab355164
Add tests for mozbuild file editing r=jewilde
https://hg.mozilla.org/integration/autoland/rev/3e1f61fc1927
Do not add newly added header files to EXPORTS automatically r=jewilde
Flags: needinfo?(tom)
Regressions: 1729481, 1726587

Re-assigning bugs to the new Mach Vendor and Updatebot Component. Guid for this change: ade7b229-ec85-41f8-bafe-9d4451bfeed1

Group: core-security
Component: General → Mach Vendor & Updatebot
Product: Firefox Build System → Developer Infrastructure
Target Milestone: 93 Branch → ---

A mass updatebot change inadvertently added a security group to bugs. Removing it. Guid for this change: 09d63db4-11a1-4820-a398-d718f112f885

Group: core-security
You need to log in before you can comment on or make changes to this bug.