bad prefs can lead to crashing and cannot subscribe to newsgroups

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
16 years ago
11 years ago

People

(Reporter: baron, Unassigned)

Tracking

(Blocks: 1 bug, {crash})

Trunk
Future
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020927
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020927

I configure mail/news to subscribe to netnews.upenn.edu, port 119
(the default, which others have said is correct), and otherwise
enter everything requested and use the default settings.  When
I click on the name of the newly created news account, I get the
menu with options such as Email, Newsgroups, Accounts, ...
One of the options is "Subscribe to news..."  When I click that,
I get a barber-pole in the little box next to "Please wait" and
nothing happens.  Only if I click "Refresh" do I get prompted for
my login name and password, which I need to read this account.
But this doesn't always work.  When it works, and I type in my
name and password, Mozilla crashes.  But the main problem is, Why
should I have to click refresh at all?  So anyone ought to be able
to replicate this even without my name (baron) and password
(available on request, but the problem is that it doesn't get that
far).  It is possible that I did something wrong in the configuration,
but there isn't that much to do, so I really doubt it.


Reproducible: Always

Steps to Reproduce:
1. configure account
2. subscribe to groups
3.

Actual Results:  
hangs

Expected Results:  
subscribe to groups

I've tried this with several builds, including the latest
(2002092708).

I don't know if this is also present in NS 6 or 7, but, if
it is, it is preventing my students from reading my course
newsgroup at the University of Pennsylvania.  Penn has now
adopted NS 6 as a "supported browser".

I suspect that this is specific to Penn, or to me, because
I could not find any reports of it, but I get plenty of reports
from students about how they can't subscribe to news (but
that might be THEIR problem).  I am marking it as "major" because
it is major in my context, but I worry about not finding it
reported already.
Using the 2002-09-27-08 RedHat 8.0 and Windows 2000 builds, as soon as I attempt
to subscribe to newsgroups from netnews.upenn.edu, I get a prompt 'Please enter
a username for news server access'.

Since I don't know your password, after I type anything (or nothing) I get, 'A
News (NNTP error occurred: user Name|pass Password|generic <prog> <args>'.

This message is coming from the server, and is returned once I failed to
authenticate (spawning a 502 error, see http://www.faqs.org/rfcs/rfc977.html,
2.4.3 under General Responses).

If you can consistently reproduce the crash, please download a build with
Talkback and install it. 

See
ftp://ftp.mozilla.org/pub/mozilla/nightly/2002-09-27-08-trunk/mozilla-win32-talkback.zip

If you can consistently reproduce the crash, please download a build with
Talkback and install it. Then, do what is necessary to reproduce the crash, and
follow the instructions for sending crash data to the server. Lastly, run the
program components/talkback.exe (Win32) or components/talkback/talkback (Unix)
and find your "Incident ID". Include this with the bug report. Please don't
paste the raw Talkback data into your bug.
Sorry, I should've just linked to the directory, since you're not on Win32.

The installer builds for Linux should have talkback: 

ftp://ftp.mozilla.org/pub/mozilla/nightly/2002-09-27-08-trunk
(Reporter)

Comment 3

16 years ago
I can reproduce the crash reliably using "refresh" after failing to
get anything with "subscribe".  But really "subscribe" should do something,
like ask for my password, and it doesn't.  The crash happens only after
that failure, and only if I hit "refresh," which I really have no reason
to do except desperation.

In any case, I've done as requested and submitted the crash data.  The
incident ID is TB11675248W, reported at 09/27/02 09:32 PM.  (I didn't
have to run anything to get this.  A window popped up with this information
in it.)
nsNntpIncomingServer::WriteHostInfoFile()
[/builds/client/linux22/seamonkey/mozilla/mailnews/news/src/nsNntpIncomingServer.cpp,
line 834]
nsNntpIncomingServer::StopPopulating()
[/builds/client/linux22/seamonkey/mozilla/mailnews/news/src/nsNntpIncomingServer.cpp,
line 1159]
nsNntpIncomingServer::OnStopRunningUrl()
[/builds/client/linux22/seamonkey/mozilla/mailnews/news/src/nsNntpIncomingServer.cpp,
line 737]
nsUrlListenerManager::BroadcastChange()
[/builds/client/linux22/seamonkey/mozilla/mailnews/base/src/nsUrlListenerManager.cpp,
line 108]
nsUrlListenerManager::OnStopRunningUrl()
[/builds/client/linux22/seamonkey/mozilla/mailnews/base/src/nsUrlListenerManager.cpp,
line 124]
nsMsgMailNewsUrl::SetUrlState()
[/builds/client/linux22/seamonkey/mozilla/mailnews/base/util/nsMsgMailNewsUrl.cpp,
line 583]
nsNNTPProtocol::CleanupAfterRunningUrl()
[/builds/client/linux22/seamonkey/mozilla/mailnews/news/src/nsNNTPProtocol.cpp,
line 649]
nsNNTPProtocol::ProcessProtocolState()
[/builds/client/linux22/seamonkey/mozilla/mailnews/news/src/nsNNTPProtocol.cpp,
line 5282]
nsMsgProtocol::OnDataAvailable()
[/builds/client/linux22/seamonkey/mozilla/mailnews/base/util/nsMsgProtocol.cpp,
line 305]
nsOnDataAvailableEvent::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/netwerk/base/src/nsStreamListenerProxy.cpp,
line 194]
nsARequestObserverEvent::HandlePLEvent()
[/builds/client/linux22/seamonkey/mozilla/netwerk/base/src/nsRequestObserverProxy.cpp,
line 116]
PL_HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/plevent.c, line 646]
PL_ProcessPendingEvents()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/plevent.c, line 578]
nsEventQueueImpl::ProcessPendingEvents()
[/builds/client/linux22/seamonkey/mozilla/xpcom/threads/nsEventQueue.cpp, line 392]
event_processor_callback()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp, line 186]
our_gdk_io_invoke()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp, line 79]
libglib-1.2.so.0 + 0xff9e (0x4038af9e)
libglib-1.2.so.0 + 0x11773 (0x4038c773)
libglib-1.2.so.0 + 0x11d39 (0x4038cd39)
libglib-1.2.so.0 + 0x11e1e (0x4038ce1e)
nsAppShell::DispatchNativeEvent()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp, line 371]
nsXULWindow::ShowModal()
[/builds/client/linux22/seamonkey/mozilla/xpfe/appshell/src/nsXULWindow.cpp,
line 299]
nsWebShellWindow::ShowModal()
[/builds/client/linux22/seamonkey/mozilla/xpfe/appshell/src/nsWebShellWindow.cpp,
line 1109]
nsContentTreeOwner::ShowAsModal()
[/builds/client/linux22/seamonkey/mozilla/xpfe/appshell/src/nsContentTreeOwner.cpp,
line 449]
nsWindowWatcher::OpenWindowJS()
[/builds/client/linux22/seamonkey/mozilla/embedding/components/windowwatcher/src/nsWindowWatcher.cpp,
line 781]
GlobalWindowImpl::OpenInternal()
[/builds/client/linux22/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line
4247]
GlobalWindowImpl::OpenDialog()
[/builds/client/linux22/seamonkey/mozilla/dom/src/base/nsGlobalWindow.cpp, line
3015]
XPTC_InvokeByIndex()
XPCWrappedNative::CallMethod()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednative.cpp,
line 1994]
XPC_WN_CallMethod()
[/builds/client/linux22/seamonkey/mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp,
line 1266]
js_Invoke() [/builds/client/linux22/seamonkey/mozilla/js/src/jsinterp.c, line 839]
js_Interpret() [/builds/client/linux22/seamonkey/mozilla/js/src/jsinterp.c, line
2803]
js_Invoke() [/builds/client/linux22/seamonkey/mozilla/js/src/jsinterp.c, line 856]
js_InternalInvoke() [/builds/client/linux22/seamonkey/mozilla/js/src/jsinterp.c,
line 931]
JS_CallFunctionValue() [/builds/client/linux22/seamonkey/mozilla/js/src/jsapi.c,
line 3431]
nsJSContext::CallEventHandler()
[/builds/client/linux22/seamonkey/mozilla/dom/src/base/nsJSEnvironment.cpp, line
1044]
nsJSEventListener::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/dom/src/events/nsJSEventListener.cpp,
line 182]
nsEventListenerManager::HandleEventSubType()
[/builds/client/linux22/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1182]
nsEventListenerManager::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/content/events/src/nsEventListenerManager.cpp,
line 1346]
nsXULElement::HandleDOMEvent()
[/builds/client/linux22/seamonkey/mozilla/content/xul/content/src/nsXULElement.cpp,
line 3470]
PresShell::HandleEventInternal()
[/builds/client/linux22/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6218]
PresShell::HandleEventWithTarget()
[/builds/client/linux22/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6188]
nsEventStateManager::CheckForAndDispatchClick()
[/builds/client/linux22/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp,
line 2857]
nsEventStateManager::PostHandleEvent()
[/builds/client/linux22/seamonkey/mozilla/content/events/src/nsEventStateManager.cpp,
line 1860]
PresShell::HandleEventInternal()
[/builds/client/linux22/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6238]
PresShell::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/layout/html/base/src/nsPresShell.cpp,
line 6141]
nsViewManager::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/view/src/nsViewManager.cpp, line 2119]
nsView::HandleEvent()
[/builds/client/linux22/seamonkey/mozilla/view/src/nsView.cpp, line 301]
nsViewManager::DispatchEvent()
[/builds/client/linux22/seamonkey/mozilla/view/src/nsViewManager.cpp, line 1926]
HandleEvent() [/builds/client/linux22/seamonkey/mozilla/view/src/nsView.cpp,
line 83]
nsWidget::DispatchEvent()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWidget.cpp, line 1476]
nsWidget::DispatchWindowEvent()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWidget.cpp, line 1365]
nsWidget::DispatchMouseEvent()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWidget.cpp, line 1505]
nsWidget::OnButtonReleaseSignal()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWidget.cpp, line 1966]
nsWindow::OnButtonReleaseSignal()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWindow.cpp, line 1667]
nsWindow::HandleGDKEvent()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsWindow.cpp, line 1777]
dispatch_superwin_event()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsGtkEventHandler.cpp,
line 961]
handle_gdk_event()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsGtkEventHandler.cpp,
line 834]
libgdk-1.2.so.0 + 0x17d6f (0x4035ad6f)
libglib-1.2.so.0 + 0x11773 (0x4038c773)
libglib-1.2.so.0 + 0x11d39 (0x4038cd39)
libglib-1.2.so.0 + 0x11eec (0x4038ceec)
libgtk-1.2.so.0 + 0x942e3 (0x402a92e3)
nsAppShell::Run()
[/builds/client/linux22/seamonkey/mozilla/widget/src/gtk/nsAppShell.cpp, line 334]
nsAppShellService::Run()
[/builds/client/linux22/seamonkey/mozilla/xpfe/appshell/src/nsAppShellService.cpp,
line 472]
main1()
[/builds/client/linux22/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp, line 1897]
main() [/builds/client/linux22/seamonkey/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 1883]
0x42017589 

If you create a new profile via ./mozilla -profilemanager, do you still see this
problem?  I still can't reproduce this yet.
Keywords: crash
(Reporter)

Comment 5

16 years ago
I tried this but the new profile doesn't have mail/news in it.
I fear I'm going to bed and will have to try this tomorrow,
although I hate to give up your involvement right now.
Still, I'm fading fast.  I will try to figure it out first
thing in the morning.  Jon
Jonathan, can you send us the snippet inside of your prefs.js file that includes
'upenn'?

Here's mine, for an example.

Seth thinks there might be something with your path to the hostinfo.dat file.

user_pref("mail.server.server10.directory", "C:\\Documents and
Settings\\Administrator\\Application
Data\\Mozilla\\Profiles\\stephend\\2686hkj6.slt\\News\\netnews.upenn.edu");
user_pref("mail.server.server10.hostname", "netnews.upenn.edu");
user_pref("mail.server.server10.max_cached_connections", 2);
user_pref("mail.server.server10.name", "netnews.upenn.edu");
user_pref("mail.server.server10.newsrc.file", "C:\\Documents and
Settings\\Administrator\\Application
Data\\Mozilla\\Profiles\\stephend\\2686hkj6.slt\\News\\netnews.upenn.edu.rc");
user_pref("mail.server.server10.type", "nntp");
user_pref("mail.server.server10.userName", "stephend");

Thanks.
Summary: can't subscribe to newsgroups → crashing and cannot subscribe to newsgroups
Confirming based on crash...
Status: UNCONFIRMED → NEW
Ever confirmed: true
accepting.  until we get some more info, I can at least bullet proof what I 
think is the crash.
Status: NEW → ASSIGNED
Target Milestone: --- → mozilla1.2beta
checked in, but not marking fixed until we figure out the real bug.
(Reporter)

Comment 11

16 years ago
I made a new profile, and that worked as it should!  So the problem was
in my original profile.  I experimented.  First, I removed all my
capability-policy stuff.  (I deleted it all by hand from prefs.js and
also renamed user.js to something else.)  That didn't help.  Then I
removed every line beginning with "mail" from prefs.js.  That helped.
News reading now works as it should (after I re-made the account).  I
was hoping to be able to check my original prefs.js, but, unfortunately,
I thought that prefs.bak was something I had made, and, in fact, Mozilla
made it, so it got overwritten and I can't recover the exact original.
However, I have had exactly the same problem on another computer (in my
office), and I still had the prefs.js file from that one.  It is long,
so I put it in http://finzi.psych.upenn.edu/~baron/prefs.js .  The part
that seems to cause the trouble is all the lines starting with "mail".
Very likely, this got loused up because I made so many attempts to get it
to work (meanwhile copying prefs.js from one computer to the other).

There is something wrong here, but it may be the result of some earlier
bug in some earlier version of Mozilla.  It doesn't seem worth tracking
down.  So I am for marking this as fixed, or at least very low priority,
unless someone else reports something similar.  If, however, someone DOES
want to track it down further, I am willing to help.

Thanks for all the suggestions.  Jon
taking a quick look at your prefs, I see a potential problem:

user_pref("mail.root.imap", "/home/baron/.mozilla/default/ImapMail");
user_pref("mail.root.nntp", "/home/jon/.mozilla/default/News");
user_pref("mail.root.none", "/home/baron/.mozilla/default/Mail");
user_pref("mail.server.server1.hostname", "netnews.upenn.edu");
user_pref("mail.server.server1.name", "Penn news");
user_pref
("mail.server.server1.newsrc.file", "/home/baron/.mozilla/default/News/newsrc-
netnews.upenn-8.edu");
user_pref("mail.server.server1.type", "nntp");
user_pref("mail.server.server1.userName", "baron");

For some reason, your server1 server doesn't have a .directory pref (did you 
remove it?)

and your default root for nntp is "/home/jon/.mozilla/default/News", where all 
the other directory like prefs in your prefs.js seem to be pointing 
to "/home/baron/.mozilla/..."

I bet with this we could now reproduce this problem.  but it sounds like you 
were editing prefs.js by hand, which can lead to problems like this.

There's not much we can do in that case, but we shouldn't crash.  I have a 
feeling that the fix I made on friday will be enough to prevent the crash, but 
I'm going to lower the priority and change the summary. 

this should not be a common thing, so we'll get to it when we get some free 
cycles.
Severity: major → minor
Summary: crashing and cannot subscribe to newsgroups → bad prefs can lead to crashing and cannot subscribe to newsgroups
futuring.  no plans to fix this during 1.2 beta.
Target Milestone: mozilla1.2beta → Future

Comment 14

16 years ago
By the definitions on <http://bugzilla.mozilla.org/bug_status.html#severity> and
<http://bugzilla.mozilla.org/enter_bug.cgi?format=guided>, crashing and dataloss
bugs are of critical or possibly higher severity.  Only changing open bugs to
minimize unnecessary spam.  Keywords to trigger this would be crash, topcrash,
topcrash+, zt4newcrash, dataloss.
Severity: minor → critical

Updated

16 years ago
Blocks: 123929
Product: Browser → Seamonkey

Updated

14 years ago
Assignee: sspitzer → mail
Status: ASSIGNED → NEW
SS in comment #12:
> ...
> 
> For some reason, your server1 server doesn't have a .directory pref (did you 
> remove it?)
> 
> and your default root for nntp is "/home/jon/.mozilla/default/News", where all 
> the other directory like prefs in your prefs.js seem to be pointing 
> to "/home/baron/.mozilla/..."
> 
> I bet with this we could now reproduce this problem.  but it sounds like you 
> were editing prefs.js by hand, which can lead to problems like this.
> 
> There's not much we can do in that case, but we shouldn't crash.  I have a 
> feeling that the fix I made on friday will be enough to prevent the crash, but 
> I'm going to lower the priority and change the summary. 
 
I removed these lines separately and together and no crash
.directory
.directory-rel

I cannot cause the subscribe problem of comment 3

WFM TB version 3 alpha 1 (20070130),  Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a2pre) Gecko/20070130 SeaMonkey/1.5a
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.