Crash in eh_rest_world_r10 at bbc news site

RESOLVED DUPLICATE of bug 154699

Status

--
critical
RESOLVED DUPLICATE of bug 154699
17 years ago
14 years ago

People

(Reporter: paul.carr, Assigned: asa)

Tracking

({crash})

Trunk
PowerPC
macOS
crash

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 5.21; Mac_PowerPC)
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en-US; rv:1.1a) Gecko/20020610

Mozilla crashes repeatably when accessing http://news.bbc.co.uk/  Crash log below

Reproducible: Always

Steps to Reproduce:
1.go to http://news.bbc.co.uk/
2.
3.

Actual Results:  
Crash after a few seconds

Expected Results:  
no crash


Date/Time:  2002-09-28 10:43:52 -0400
OS Version: 10.2.1 (Build 6D52)
Host:       Paul-Carrs-Computer.local.

Command:    Mozilla
PID:        952

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000034

Thread 0:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9284ee30 in JVM_GetCPMethodClassNameUTF
 #4   0x92861a94 in JVM_Send
 #5   0x9285eb14 in JVM_FillInStackTrace
 #6   0x92868468 in JVM_DoPrivileged
 #7   0x9288e0e0 in JVM_GetMethodIxExceptionTableEntry
 #8   0x92883e80 in JVM_DefineClass
 #9   0x929ba848 in eh_rest_world_r10
 #10  0x928499b8 in __moddi3
 #11  0x928af2cc in JVM_IsNaN
 #12  0x04b17c90 in 0x4b17c90
 #13  0x04b25d90 in 0x4b25d90
 #14  0x04b24dcc in 0x4b24dcc
 #15  0x04b26f08 in 0x4b26f08
 #16  0x04b19e60 in 0x4b19e60
 #17  0x04a1768c in 0x4a1768c
 #18  0x04a1768c in 0x4a1768c
 #19  0x04a175cc in 0x4a175cc
 #20  0x04a175cc in 0x4a175cc
 #21  0x04a175cc in 0x4a175cc
 #22  0x04a175cc in 0x4a175cc
 #23  0xa2843c38 in _ZTSSt13bad_exception
 #24  0x92838bdc in JVM_CurrentTimeMillis
 #25  0x92872ed4 in JVM_GetCPClassNameUTF
 #26  0x92865c80 in JVM_DoPrivileged
 #27  0x04a19668 in 0x4a19668
 #28  0x04a175cc in 0x4a175cc
 #29  0xa2843c38 in _ZTSSt13bad_exception
 #30  0x92838bdc in JVM_CurrentTimeMillis
 #31  0x92872ed4 in JVM_GetCPClassNameUTF
 #32  0x9288f144 in JVM_MonitorNotifyAll
 #33  0x9285fd68 in JVM_GetCPFieldSignatureUTF
 #34  0x92844a98 in JVM_GetClassLoader
 #35  0x92875e64 in JVM_GetCPClassNameUTF
 #36  0x9288199c in JVM_DefineClass
 #37  0x92869ed4 in JVM_DoPrivileged
 #38  0x928480dc in __moddi3
 #39  0x04a1fd7c in 0x4a1fd7c
 #40  0xa2843c38 in _ZTSSt13bad_exception
 #41  0x92838bdc in JVM_CurrentTimeMillis
 #42  0x92872ed4 in JVM_GetCPClassNameUTF
 #43  0x9288f144 in JVM_MonitorNotifyAll
 #44  0x9285fd68 in JVM_GetCPFieldSignatureUTF
 #45  0x92844a98 in JVM_GetClassLoader
 #46  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #47  0x92844a98 in JVM_GetClassLoader
 #48  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #49  0x92844a98 in JVM_GetClassLoader
 #50  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #51  0x92844a98 in JVM_GetClassLoader
 #52  0x9285fc40 in JVM_GetCPFieldSignatureUTF
 #53  0x92844a98 in JVM_GetClassLoader
 #54  0x928452e8 in JVM_GetMethodIxExceptionTableLength
 #55  0x928a22c4 in JVM_Close
 #56  0x8cfd23e4 in 
_ZN43com_apple_mrj_JavaEmbedding_JE_AppletViewer20intitializeMethodIDsEP7JNI
Env_
 #57  0x8cfd1dec in _Z23intitializeAllMethodIDsP7JNIEnv_
 #58  0x8cfd3068 in _Z17InitJavaEmbeddingRP7JNIEnv_
 #59  0x8cfd57d4 in CreateJavaApplet
 #60  0x020b6734 in loadApplet__10MRJContextFv
 #61  0x020b7298 in setWindow__10MRJContextFP14nsPluginWindow
 #62  0x020b2ea4 in SetWindow__17MRJPluginInstanceFP14nsPluginWindow
 #63  0x01f2efec in 
InstantiateEmbededPlugin__16nsPluginHostImplFPCcP6nsIURIP22nsI
 #64  0x022ac794 in 
InstantiatePlugin__13nsObjectFrameFP14nsIPresContextR19nsHTMLR
 #65  0x022ab4a0 in 0x22ab4a0
 #66  0x022e07c0 in 0x22e07c0
 #67  0x022d9828 in 0x22d9828
 #68  0x022d9518 in 
DoReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowStateR12n
 #69  0x022d9188 in 
DoReflowInlineFramesAuto__12nsBlockFrameFR18nsBlockReflowState
 #70  0x022d8f08 in 
ReflowInlineFrames__12nsBlockFrameFR18nsBlockReflowState19nsLi
 #71  0x022d7318 in 
ReflowLine__12nsBlockFrameFR18nsBlockReflowState19nsLineList_i
 #72  0x022d6904 in 0x22d6904
 #73  0x022d4d2c in 
Reflow__12nsBlockFrameFP14nsIPresContextR19nsHTMLReflowMetrics
 #74  0x022fcdb8 in 
DoReflowBlock__20nsBlockReflowContextFR17nsHTMLReflowState14ns
 #75  0x022fc818 in 
ReflowBlock__20nsBlockReflowContextFP8nsIFrameRC6nsRectiR18nsC
 #76  0x022d8888 in 0x22d8888
 #77  0x022d6f3c in 0x22d6f3c
 #78  0x022d6904 in 0x22d6904
 #79  0x022d4d2c in 
Reflow__12nsBlockFrameFP14nsIPresContextR19nsHTMLReflowMetrics
 #80  0x0223246c in 
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #81  0x023d19bc in 
Reflow__11CanvasFrameFP14nsIPresContextR19nsHTMLReflowMetricsR
 #82  0x0238ea00 in 
Reflow__19nsBoxToBlockAdaptorFR16nsBoxLayoutStateP14nsIPresCon
 #83  0x0238e3e4 in DoLayout__19nsBoxToBlockAdaptorFR16nsBoxLayoutState
 #84  0x02388fec in Layout__5nsBoxFR16nsBoxLayoutState
 #85  0x023bad9c in 0x23bad9c
 #86  0x02388fec in Layout__5nsBoxFR16nsBoxLayoutState
 #87  0x0234a1e4 in 
Reflow__10nsBoxFrameFP14nsIPresContextR19nsHTMLReflowMetricsRC
 #88  0x0223246c in 
ReflowChild__16nsContainerFrameFP8nsIFrameP14nsIPresContextR19
 #89  0x0231a2f0 in 
Reflow__13ViewportFrameFP14nsIPresContextR19nsHTMLReflowMetric
 #90  0x02246e98 in 
Dispatch__17IncrementalReflowFP14nsIPresContextR19nsHTMLReflow
 #91  0x02257ec4 in ProcessReflowCommands__9PresShellFi
 #92  0x02257908 in HandlePLEvent__FP11ReflowEvent
 #93  0x002d0270 in PL_HandleEvent
 #94  0x002d00dc in PL_ProcessPendingEvents
 #95  0x002760fc in ProcessPendingEvents__16nsEventQueueImplFv
 #96  0x017a8b9c in ProcessPLEventQueue__26nsMacNSPREventQueueHandlerFv
 #97  0x017a8a40 in 
RepeatAction__26nsMacNSPREventQueueHandlerFRC11EventRecord
 #98  0x01426b14 in DoRepeaters__8RepeaterFRC11EventRecord
 #99  0x017bef58 in DispatchEvent__16nsMacMessagePumpFiP11EventRecord
 #100 0x017bec80 in DoMessagePump__16nsMacMessagePumpFv
 #101 0x017be5fc in Run__10nsAppShellFv
 #102 0x016e3afc in Run__17nsAppShellServiceFv
 #103 0x001a3f1c in main1__FiPPcP11nsISupports
 #104 0x001a495c in main

Thread 1:
 #0   0x9000582c in syscall
 #1   0x90515d9c in BSD_waitevent
 #2   0x9051576c in CarbonSelectThreadFunc
 #3   0x90021428 in _pthread_body

Thread 2:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x9051dda0 in CarbonOperationThreadFunc
 #3   0x90021428 in _pthread_body

Thread 3:
 #0   0x90042d68 in semaphore_timedwait_signal_trap
 #1   0x9003ef94 in _pthread_cond_wait
 #2   0x90233470 in TSWaitOnSemaphoreCommon
 #3   0x9023c298 in TimerThread
 #4   0x90021428 in _pthread_body

Thread 4:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90233454 in TSWaitOnSemaphoreCommon
 #3   0x90248b2c in _Z15AsyncFileThreadPv
 #4   0x90021428 in _pthread_body

Thread 5:
 #0   0x9003f188 in semaphore_wait_signal_trap
 #1   0x9003efa4 in _pthread_cond_wait
 #2   0x90525b90 in CarbonInetOperThreadFunc
 #3   0x90021428 in _pthread_body

Thread 6:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x928ec28c in JNI_CreateJavaVM_Impl
 #3   0x928ec224 in JNI_CreateJavaVM_Impl
 #4   0x928a51fc in JVM_GetClassMethodsCount
 #5   0x90021428 in _pthread_body

Thread 7 Crashed:
 #0   0x929ba640 in eh_rest_world_r10
 #1   0x92857a38 in JVM_GetMethodIxLocalsCount
 #2   0x9285c128 in JVM_GetCPMethodNameUTF
 #3   0x928917f4 in JVM_MonitorNotifyAll
 #4   0x92886e6c in JVM_SetThreadPriority
 #5   0x92864964 in JVM_Send
 #6   0x9290114c in JNI_CreateJavaVM_Impl
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

Thread 8:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x04a19668 in 0x4a19668
 #7   0x04a1768c in 0x4a1768c
 #8   0x04a1768c in 0x4a1768c
 #9   0xa2843c38 in _ZTSSt13bad_exception
 #10  0x92838bdc in JVM_CurrentTimeMillis
 #11  0x92878c28 in JVM_FindClassFromClass
 #12  0x92892c90 in JVM_IsSameClassPackage
 #13  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #14  0x928787a0 in JVM_FindClassFromClass
 #15  0x928a51fc in JVM_GetClassMethodsCount
 #16  0x90021428 in _pthread_body

Thread 9:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x92845d80 in JVM_ArrayCopy
 #4   0x9285d620 in JVM_MonitorNotify
 #5   0x9285e2f8 in JVM_MonitorWait
 #6   0x04a19668 in 0x4a19668
 #7   0x04a1768c in 0x4a1768c
 #8   0x04a175cc in 0x4a175cc
 #9   0x04a175cc in 0x4a175cc
 #10  0xa2843c38 in _ZTSSt13bad_exception
 #11  0x92838bdc in JVM_CurrentTimeMillis
 #12  0x92878c28 in JVM_FindClassFromClass
 #13  0x92892c90 in JVM_IsSameClassPackage
 #14  0x9288cf70 in JVM_GetMethodIxExceptionTableEntry
 #15  0x928787a0 in JVM_FindClassFromClass
 #16  0x928a51fc in JVM_GetClassMethodsCount
 #17  0x90021428 in _pthread_body

Thread 10:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283de9c in JVM_NewInstance
 #3   0x92844e18 in JVM_GetClassLoader
 #4   0x92844ba4 in JVM_GetClassLoader
 #5   0x928a51fc in JVM_GetClassMethodsCount
 #6   0x90021428 in _pthread_body

Thread 11:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x92903300 in JVM_InitProperties
 #5   0x92903138 in JVM_InitProperties
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

Thread 12:
 #0   0x90074328 in mach_msg_trap
 #1   0x90006670 in mach_msg
 #2   0x9283ddf4 in JVM_NewInstance
 #3   0x9285eb40 in JVM_FillInStackTrace
 #4   0x9288890c in JVM_StartThread
 #5   0x92876c10 in JVM_FindLoadedClass
 #6   0x928787a0 in JVM_FindClassFromClass
 #7   0x928a51fc in JVM_GetClassMethodsCount
 #8   0x90021428 in _pthread_body

PPC Thread State:
  srr0: 0x929ba640 srr1: 0x0000f030                vrsave: 0x00000000
   xer: 0x00000000   lr: 0x92857a38  ctr: 0x928498e0   mq: 0x00000000
    r0: 0x00000030   r1: 0xf0407a40   r2: 0x92857a38   r3: 0x6c1631d8
    r4: 0x6c1631d8   r5: 0x6c163200   r6: 0x00000000   r7: 0x0000000c
    r8: 0xa2833a58   r9: 0x00000000  r10: 0x00000008  r11: 0x00000b18
   r12: 0x928498e0  r13: 0xa282bd1c  r14: 0x00000000  r15: 0xf0407b90
   r16: 0xa28320f8  r17: 0x00000000  r18: 0x00160000  r19: 0xa282bd1c
   r20: 0xf0407b60  r21: 0xa282bd1c  r22: 0xa282bd1c  r23: 0xa282bd1c
   r24: 0xbfffad3c  r25: 0x03c10950  r26: 0x00000000  r27: 0x00000000
   r28: 0xa28305b0  r29: 0x03c0bb10  r30: 0x6c1631d8  r31: 0x9285bd1c

Updated

17 years ago
Severity: normal → critical
Keywords: crash

Comment 1

17 years ago
WFM, Build ID: 2002092708, Mac OS X v10.1.5

*** This bug has been marked as a duplicate of 154699 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 3

17 years ago
Paul, for future reference, you should always test possible bugs in *recent*
builds. Your build is more than four months old, positively ancient for
bug-reporting purposes.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.