Closed Bug 1713850 Opened 6 months ago Closed 6 months ago

New thin icons look worse on 1x screens

Categories

(Firefox :: Toolbars and Customization, defect)

Firefox 91
defect

Tracking

()

RESOLVED DUPLICATE of bug 1704274

People

(Reporter: joshas, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton][proton-icons])

Attachments

(1 file)

Attached image icons.png

User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

Compared, how toolbar icons look on Firefox 88 and new Firefox 91 nightly release on standard, non HiDPI screen. Fedora 33.

Actual results:

New thin icons look worse, they have noticeable edges and some grey outlines. Looks like that icons were not aligned to pixel grid, there are visible single pixel "aliasing" effects.

Expected results:

Consider "normal", non HiDPI screens when designing icons, to keep them looking great.

Hi, I will set a component to have a starting point for this.

Has Regression Range: --- → no
Has STR: --- → no
Component: Untriaged → Toolbars and Customization
Whiteboard: proton

Is there a bug to dupe this one to, sfoster?

Blocks: proton-icons
Flags: needinfo?(sfoster)
Whiteboard: proton → [proton][proton-icons]

I think this is the same as bug 1704274. Its another case that is probably dependent on display hardware, as that screenshot looks fine to me.

Status: UNCONFIRMED → RESOLVED
Closed: 6 months ago
Flags: needinfo?(sfoster)
Resolution: --- → DUPLICATE
Duplicate of bug: 1704274
You need to log in before you can comment on or make changes to this bug.