Closed Bug 1714286 Opened 5 months ago Closed 4 months ago

Caret is not Shown in Content-Editable Element of Web Component

Categories

(Core :: DOM: Editor, defect, P3)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 1496769

People

(Reporter: christian, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

open the attached Html file in Firefox (tested with Firefox 89 on Windows)

  • click on "text input" --> caret is shown
  • click on "content editable" --> no caret is shown

the html contains a web component with a text inputs and one content-editable span.

Actual results:

caret does not appear

Note: the caret does appear if you click outside the web component and then "content-editable" again

Note: there is no problem if the content editable is not contained within a web component.

Expected results:

caret should appear in a content-editable node when changing the input focus within the web component

Component: Untriaged → DOM: Editor
Product: Firefox → Core
Blocks: shadowdom
Status: UNCONFIRMED → NEW
Ever confirmed: true

Kagami, can you take a look. please?

Severity: -- → S3
Flags: needinfo?(krosylight)
Priority: -- → P3

This look very similar if not same with:

Status: NEW → RESOLVED
Closed: 4 months ago
Flags: needinfo?(krosylight)
Resolution: --- → DUPLICATE
Duplicate of bug: 1496769
You need to log in before you can comment on or make changes to this bug.