Closed Bug 1714332 Opened 4 months ago Closed 3 months ago

CSS "clip-path" glitches on high-res Macs

Categories

(Core :: Graphics, defect, P3)

Firefox 88
defect

Tracking

()

RESOLVED DUPLICATE of bug 1707154

People

(Reporter: valerian.tschopp, Unassigned)

References

Details

Attachments

(4 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

If you use "clip-path" on high-res Macs (Retina 5K, 27-inch, 2020) the clipped element starts glitching at 2048px width.

Actual results:

Background starts glitching (artifacts appear).

Expected results:

The CSS "clip-path" property should work as expected and a wavy background should be visible.

The Bugbug bot thinks this bug should belong to the 'Core::Layout' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Layout
Product: Firefox → Core

I don't have a 5K/27" display to reproduce this locally, but in general I don't think Layout should care about the 2048px (or 4096 device pixels) width here - this sounds more like a Graphics issue to me.

Component: Layout → Graphics
See Also: → 1719522
Blocks: gfx-triage
Severity: -- → S3
Priority: -- → P3

Thank you for posting. We might be hitting a 4K texture size limit. Can you please attach a video of the problem? Also it would help to have a more specific URL that shows the problem -- the css-tricks page doesn't have an obvious background gradient.

Flags: needinfo?(valerian.tschopp)

I get different content on the front page of css-tricks today than I did yesterday, so it may be we're not seeing what the reporter was referring to at all. Could you give an example of a specific, static site where the issue occurs? (I'm guessing this will actually turn out to be the same as bug 1719522.)

Attached image Current result

Actual result.

Flags: needinfo?(valerian.tschopp)
Attached image Wanted result

Wanted result (fixed in Firefox Developer Edition 90.0b7).

(In reply to Brad Werth [:bradwerth] (PTO until July 16) from comment #3)

Thank you for posting. We might be hitting a 4K texture size limit. Can you please attach a video of the problem? Also it would help to have a more specific URL that shows the problem -- the css-tricks page doesn't have an obvious background gradient.

I added screenshots and will add the corresponding HTML and CSS files. The issue was recently fixed with FF Dev. 90.0b7 - so everything should be working again.

Attached file HTML file
Attached file CSS file
Attachment #9230587 - Attachment description: Source code of the HTML file producing such bug. → HTML file
Attachment #9230586 - Attachment description: firefox_wanted-result.png → Wanted result
Attachment #9230585 - Attachment description: firefox_bug.png → Current result

This was fixed by bug 1707154.

Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1707154
No longer blocks: gfx-triage
You need to log in before you can comment on or make changes to this bug.