Open Bug 1714437 Opened 4 months ago Updated 4 months ago

Flickery graphics on M1 MacBook Air

Categories

(Core :: Graphics: WebRender, defect, P3)

ARM64
macOS
defect

Tracking

()

REOPENED

People

(Reporter: overholt, Unassigned)

Details

Attachments

(2 files)

See the videos I'll attach. Weird flickering in release (89) on an up to date (macOS 11.4) late 2020 M1 MacBook Air. Doesn't occur on the same machine in Nightly (and didn't while Nightly was 89).

Video of when I first noticed it: https://drive.google.com/file/d/1Tturipq-Yip5nK4mdVdxmxEkJXUKqmP4/view?usp=sharing

Video of a second time I noticed it attached.

Blocks: gfx-triage

Hilariously, it looks like I somehow manually set SWGL to be on. With those prefs set to default, things look great! :)

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → INVALID

It still shouldn't flicker with swgl on. The priority for fixing it is just low. Markus, can you reproduce this?

Status: RESOLVED → REOPENED
Flags: needinfo?(mstange.moz)
Resolution: INVALID → ---

I've been running swgl on my M1 machine for a few weeks now and haven't noticed anything like this. But I've been running Nightly, not Release, so maybe the bug is already fixed.

Flags: needinfo?(mstange.moz)

I will test 89 release.

89 seems to work well so far, no flicker.

Severity: -- → S3
Priority: -- → P3
No longer blocks: gfx-triage
Severity: S3 → S4
You need to log in before you can comment on or make changes to this bug.