Closed Bug 1714463 Opened 8 months ago Closed 7 months ago

`hg replicatesync` should not publish messages with heads that cannot be pulled

Categories

(Developer Services :: Mercurial: hg.mozilla.org, defect)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: sheehan, Assigned: sheehan)

References

Details

The cause of bug 1714346 was the hg replicatesync message publishing a commit hash in it's "heads" key that cannot be replicated. We should avoid this issue moving forward.

Since it isn't critical to run replicatesync after creating bundles (it's mostly "for good measure") I've deactivated that section of code while I work on a fix.

Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/993ed80a5e6d
bundles: don't run replicatesync on copyfrom bundle repos

Status: NEW → RESOLVED
Closed: 8 months ago
Resolution: --- → FIXED
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Pushed by cosheehan@mozilla.com:
https://hg.mozilla.org/hgcustom/version-control-tools/rev/c4dd2a09ac3d
bundles: do not run replicatesync for try repo when generating bundles

Status: REOPENED → RESOLVED
Closed: 8 months ago7 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.