Closed Bug 1714478 Opened 3 months ago Closed 15 days ago

Remove Bookmark in menu should be renamed to Delete Bookmark

Categories

(Firefox :: Bookmarks & History, enhancement, P3)

Firefox 89
enhancement
Points:
1

Tracking

()

RESOLVED FIXED
93 Branch
Tracking Status
firefox93 --- fixed

People

(Reporter: andy2020, Assigned: Gijs)

References

(Blocks 1 open bug)

Details

(Whiteboard: [proton-door-hangers] )

Attachments

(2 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Right clicked a bookmark because I wanted to delete it.

Actual results:

Searched the menu for Delete and did not find it.

Expected results:

Firefox should use the correct word in the drop down menu. Delete means erase (i.e. rendered nonexistent or nonrecoverable), while remove denotes take away and set aside (but kept in existence). Please rename Remove Bookmark to Delete Bookmark or better yet do what Chrome does and just use the word Delete.

The Bugbug bot thinks this bug should belong to the 'Firefox::Bookmarks & History' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Bookmarks & History

100 % agree , I can already picture my call volume with users "where is delete?". Chrome and Edge both use Delete, and before this update Firefox did as well. Also moving it in the menu should be reverted as well. Firefox should stick with standard people are used to. Delete.

Marking enhancement this as New in order to gain more visibility.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [proton-door-hangers]

Hi Mark,

What does this mean?

Whiteboard: [proton-door-hangers]

(In reply to Andy Bajka from comment #4)

What does this mean?

Whiteboard: [proton-door-hangers]

We track things in a variety of ways, this should get it triaged by the correct team in this instance.

+1 for use delete

It all cases i would do it like so:

  • "&Delete Folder"
  • "&Delete Bookmark"

if u want to stick to remove then, IMO also the mnemonic ( ie the letter to use to execute it w/o clicking) should be aligned deleting a bookmark and a folder:

in 89.0.2 it's like so:

  • "Re&move Folder"
  • "R&emove Bookmark"

very anoying

3 Reasons to change it to "Delete":

  1. "Delete" means destroy, "Remove" means move somewhere else.
  2. The word "Delete" is used universally by all filing systems and applications. Everyone understands what it means.
  3. "Rename bookmark" and "Remove bookmark" sit next to each other in the context menu and look almost identical. This makes it much slower to find the correct one.

I also don't see the point in this update, and think it is a step backwards.

Right-clicking and selecting "Delete Bookmark/Folder" from the very bottom of the drop down list has been the standard for so long, and so cemented in the muscle memory of long time users, that it will be a major annoyance for them.

So please:

  • Revert from "Remove Bookmark" to "Delete Bookmark"
  • Revert from "Remove Folder" to "Delete Folder"
  • Place them at the bottom of the select list, after right-clicking

I have been thinking some more about this and agree with the original suggestion by @Andy Bajka: Just use the word Delete:

  • Remove "Remove Bookmark"
  • Remove "Remove Folder"
  • Add a universal "Delete" option at the bottom of the drop-down, which works for both Bookmarks and Folders.

Agree with comment above. It is obvious what is being deleted, so just have the word "Delete" alone, getting rid of unnecessary words, making the command more distinctive and easier to spot.

Duplicate of this bug: 1723337

Romain, please can you take a look at this? I think there's potentially two issues that are from Proton. The first is the inconsistent Delete / Remove, which needs looking at. The second is the remove vs delete naming.

Flags: needinfo?(rtestard)

I recently discovered that the Firefox GUI used to have just "Delete" at the bottom:
https://www.wikihow.com/images/3/3b/Delete-a-Bookmark-in-Mozilla-Firefox-Step-5-Version-2.jpg

Meridel, per discussion can you please help review?

Flags: needinfo?(rtestard) → needinfo?(mwalkington)

Context on past decisions:
-We went with "remove" rather than "delete" because the item remains in your History. I don't think other browsers draw that distinction, though, and maybe that distinction isn't important.
-We updated "Edit..." to "Rename" for the folder item because the only action you CAN take is renaming. I see the value in being consistent from one context menu to the next.

In sum, I think it's fine to make the label changes here in red. We should not change up order, though.

Gijs, since you worked with me on these, any objections or context I am missing?

Flags: needinfo?(mwalkington) → needinfo?(gijskruitbosch+bugs)
Assignee: nobody → gijskruitbosch+bugs
Severity: -- → N/A
Status: NEW → ASSIGNED
Flags: needinfo?(gijskruitbosch+bugs)
Priority: -- → P3

Gijs, since you worked with me on these, any objections or context I am missing?

I don't think so, but I passed the review of the patch to implement this to Marco to make sure.

Points: --- → 1
Duplicate of this bug: 1721500
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/faee833c5198
go back to using 'edit' and 'delete' for bookmark menus, r=mak,fluent-reviewers,flod
Status: ASSIGNED → RESOLVED
Closed: 15 days ago
Resolution: --- → FIXED
Target Milestone: --- → 93 Branch

"Remove Bookmark" text still exists on button in address bar star popup (Edit this bookmark (Ctrl+D)) in FF 93.0b2.
Should be also "Delete Bookmark".

  1. The original bug report actually request a rename to "Delete", which I and other users here agree with. As I mentioned above, this is how it used to be. I will update the title to match this proposal:

    ... or better yet [...] just use the word Delete.

  2. How about my suggestion of putting "Delete" at the bottom of the drop-down (also like it used to be) for both Bookmarks and Folders?

I can't edit the title, but I would suggest to:

  1. Re-open and update title to "Remove Bookmark" in menu should be renamed to "Delete"
  2. Place "Delete" firmly at the bottom of the drop-down , or create a follow up issue?

Re-open and update title to "Remove Bookmark" in menu should be renamed to "Delete"

The string was renamed to "Delete Bookmark", not to "Delete", so there is no point in doing this change of the bug title.

Place "Delete" firmly at the bottom of the drop-down , or create a follow up issue?

It was already decided that the order won't be changed (see comment #18).

(In reply to ser.maltsev from comment #24)

"Remove Bookmark" text still exists on button in address bar star popup (Edit this bookmark (Ctrl+D)) in FF 93.0b2.
Should be also "Delete Bookmark".

please file a separate bug.

(In reply to tero gusto from comment #25)

  1. The original bug report actually request a rename to "Delete", which I and other users here agree with.

Bugs should never be reopened because you disagree with the fix, you can always open a new bug. That said, my understanding is that the change from a generic Delete to Delete Bookmark/Folder was done on purpose to clarify the menu items, I don't think it will be undone that easily.

Thanks for fast replies Sören Hentzschel and Marco Bonardo, and for clarifying the best approach, I really appreciate it.

I have created bug 1729878 to further improve the Delete function in the Bookmark drop-down, since I think this would be the optimal solution.

Anyone following along here who agrees should feel free to air their support in bug 1729878 :-)

You need to log in before you can comment on or make changes to this bug.