Closed Bug 171467 Opened 18 years ago Closed 11 years ago

Run check on bookmark validity

Categories

(Firefox :: Bookmarks & History, enhancement)

enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 8648

People

(Reporter: primorec, Unassigned)

References

(Depends on 1 open bug)

Details

Please ADD to "Manage bookmarks" a button (option) which will do the following:

- when the option is clicked | selected | turned on the mozilla should start
  connecting to the URL specified in the "Bookmark" file
- should happen in BACKGROUND ...  NO RENDERING on the screen !!!!
- mozilla should parse the page in background  and 
   if it finds the code 404  or
   if the the connection times out

  the mozilla should create an VISIBLE HTML page which will contain
  all the "failing" URLs.

The user should have an option to delete | remove | do nothing  with dead
bookmark URL.


Rationale:
Users (including me) collected over time a tremendeous amount of URLs
which, in genereal,  stop working after whille. INTERNET is very dynamic
enviroment. Not a lot of people want to spend a time to go through their
bookmarks and check which one works and which one does not work anymore


through that VISIBLE HTML page
Please ADD to "Manage bookmarks" a button (option) which will do the following:

- when the option is clicked | selected | turned on, the mozilla should start
  connecting to the URL specified in the "Bookmark" file
- this process should happen in BACKGROUND ...  NO RENDERING on the screen !!!!
- mozilla should parse the page in background  and 
   if it finds the code 404  or
   if the connection times out

  then the mozilla should create an VISIBLE HTML page which will contain
  all the "failing" URLs.

The user should have an option to delete | remove | do nothing  with dead
bookmark URL through that VISIBLE HTML page

Rationale:
Users (including me) collected over time a tremendous amount of URLs
which, in general,  stop working after while. INTERNET is very dynamic
environment. Not a lot of people want to spend a time to go through their
bookmarks and check which one works and which one does not work anymore
Tweaking summary, severity, platform and OS.
URL: none
Severity: normal → enhancement
OS: Linux → All
Hardware: PC → All
Summary: bookmark management proposal (ENHANCEMENT) → [RFE] Check for dead bookmarks
Dependant on bug 36339 like bug 36318?
I believe this is a good idea.  Bookmarks should also get updated if redirected.
Looks related to bug #8648.
I'm confirming this bug as it is a valid request and I have found no dupes.

As I see it, the functionality should be to run a check on all or some of the
bookmarks, and act as described in 8648.

Also adding UI keyword, so we can find the best solution for this kind of mass check

Status: UNCONFIRMED → NEW
Depends on: 8648
Ever confirmed: true
Keywords: ui
Summary: [RFE] Check for dead bookmarks → Run check on bookmark validity
*** Bug 219135 has been marked as a duplicate of this bug. ***
*** Bug 219135 has been marked as a duplicate of this bug. ***
> The user should have an option to delete | remove | do nothing  with dead
> bookmark URL through that VISIBLE HTML page

Please add MOVE to the list of options - Personally I like to keep dead
bookmarks in an "obsolete" folder. Maybe that is what is meant by REMOVE since I
see no difference between REMOVE and DELETE.
Mass reassign of my non-Firefox bugs to ben_seamonkey@hotmail.com
Assignee: bugs → ben_seamonkey
Product: Browser → Seamonkey
An additional suggestion:

- For each bookmark tested, increment a counter if the test fails, clear the counter if the test succeeds
- Allow the user to set a threshold at which a link is considered "dead"
- Allow the user to select from a list of actions to be performed on "dead" links, including "delete", "move to folder...", "display in alternate font/color", etc.
- Create some mechinism to perform this task automatiacally at selected intervals.
Product: Mozilla Application Suite → Firefox
Assignee: ben_seamonkey → nobody
QA Contact: claudius → bookmarks
Didn't the old Netscape have a bookmark monitoring function which would let you run it at will, and go out and flag questionable, changed, or missing ones?
(In reply to comment #12)
> Didn't the old Netscape have a bookmark monitoring function which would let you
> run it at will, and go out and flag questionable, changed, or missing ones?

Something did--I was thinking it was the MultiZilla extension I used to use.

Shouldn't this move to the Places component now? So moving, feel free to revert as appropriate.

Component: Bookmarks → Places
QA Contact: bookmarks → places
Flags: blocking-firefox3?
Duplicate of this bug: 356418
Not blocking, far too late for changes of this type.
Flags: blocking-firefox3? → blocking-firefox3-
Can we get a blocking Firefox 4 then?
Duplicate of this bug: 426206
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 8648
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.