Closed Bug 1714887 Opened 4 months ago Closed 2 months ago

[Proton] Proton Tab/Toolbar theme incompatible with "compact" setting, looks horrible

Categories

(Firefox :: Theme, enhancement)

Firefox 88
enhancement

Tracking

()

VERIFIED WONTFIX

People

(Reporter: bugs, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [Proton - Hamburguer Menu])

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:88.0) Gecko/20100101 Firefox/88.0

Steps to reproduce:

  1. Run Firefox 88, and set the UI to "compact" mode via the Customize tool
  2. Open a few tabs to see how tightly packed it is (as intended)
  3. Upgrade to Firefox 89
  4. Open a few tabs to see... wait, where are the tabs? Where are the clearly deliniated tabs?

Actual results:

The entire tabbar is replaced by an Apple Touch Strip or touch control with no obvious buttons, tabs, or other delineation. It has also increased padding that is the same color as the background.

Expected results:

Ether:

  • The tabbar is unchanged
  • A tab opened to ask about making the change to Proton or keeping the classic UI.

I wouldn't mind if this was more of a theme and it could be tweaked like in past Firefox versions (around v40 or so). But that doesn't seem to be the case anymore.

The Bugbug bot thinks this bug should belong to the 'Firefox::Theme' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Theme

Thank you for your report.
There has been a major design change in Firefox and Themes are part of this change. You can read more about these changes here: https://blog.mozilla.org/en/products/firefox/new-firefox-coming-june-1/.
I'll mark this issue as an Enhancement and I'll set a component to have a starting point for this.
Thanks!

Status: UNCONFIRMED → NEW
Type: defect → enhancement
Ever confirmed: true
Whiteboard: [Proton - Hamburguer Menu]

(In reply to Kelly Price from comment #0)

Ether:

  • The tabbar is unchanged

We believe the new tabstrip is an improvement, or we wouldn't have changed it. I'm sorry you don't like it.

  • A tab opened to ask about making the change to Proton or keeping the classic UI.

We don't have the resources to keep 2 competing implementations of the same thing around forever (and to do it every time we change it), so unfortunately we won't be doing this.

Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → WONTFIX

Unfortunately, this means "Compact" has been removed, which is a bug.

If you can make a more compact Proton implementation with better contrast under the Dark theme (take out all that padding, it's making Firefox look like a non-red panda), that would be more acceptable than breaking people's workflows.

Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---

this means "Compact" has been removed, which is a bug.

No, that's not a bug. The compact mode was deprecated, see https://support.mozilla.org/en-US/kb/compact-mode-workaround-firefox.

Status: REOPENED → RESOLVED
Closed: 2 months ago2 months ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED

So, to be clear, there are some other bugs still open about e.g. the height of the browser UI, and about making the active/selected tab easier to distinguish, which if/when fixed (unclear right now whether/how that'll happen) may help your specific usecase. But the suggestions in this bug to somehow keep the old theme around aren't ones that we're going to be able to take up, which is why I closed it.

Can you mention those here? A lot of those bugs match up a lot of my gripes about this theme. I can sort through them and link as appropriate.

You need to log in before you can comment on or make changes to this bug.