Closed Bug 1715547 Opened 3 years ago Closed 2 years ago

Remove the Inner interface from ServiceWorker, ServiceWorkerContainer, and ServiceWorkerRegistration

Categories

(Core :: DOM: Service Workers, task)

task

Tracking

()

RESOLVED FIXED
107 Branch
Tracking Status
firefox107 --- fixed

People

(Reporter: ytausky, Assigned: edenchuang)

References

(Blocks 1 open bug)

Details

Crash Data

Attachments

(4 files, 1 obsolete file)

With child intercept code gone, we could remove a layer of abstraction that was introduced to accommodate two different implementations.

Assignee: nobody → ytausky
Status: NEW → ASSIGNED
Assignee: ytausky → jstutte
Assignee: jstutte → echuang

Depends on D138999

Pushed by echuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/85b20f601145
Remove ServiceWorkerRegistration::Inner r=asuth
https://hg.mozilla.org/integration/autoland/rev/8af1f4a4be08
Remove ServiceWorkerContainer::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/c8985e7c6a71
Remove ServiceWorker::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/c2114b608577
Remove ServiceWorkerPrivate::Inner r=asuth,dom-worker-reviewers

Backed out 4 changesets (bug 1715547) for causing leakcheck failures in ServiceWorkerPrivate.

Backout link: https://hg.mozilla.org/integration/autoland/rev/e6ea00f944000c239404e8796c93b43691b5c055

Failure log

Push with failure

Flags: needinfo?(echuang)

Comment on attachment 9276872 [details]
Bug 1715547 - Blocking SerivceWorker interception for no_cors cross-origin range request. r=#dom-worker-reviewers

Revision D146552 was moved to bug 1762078. Setting attachment 9276872 [details] to obsolete.

Attachment #9276872 - Attachment is obsolete: true
Flags: needinfo?(echuang)
Pushed by echuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/93250012e5ac
Remove ServiceWorkerRegistration::Inner r=asuth
https://hg.mozilla.org/integration/autoland/rev/6d0a9db1638c
Remove ServiceWorkerContainer::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/b02cb05ea06c
Remove ServiceWorker::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/64e584ac229b
Remove ServiceWorkerPrivate::Inner r=asuth,dom-worker-reviewers
Regressions: 1790762

Backed out for causing frequent crashes:
https://hg.mozilla.org/integration/autoland/rev/58596af91c9397ae9e5e7edab9eb4f2bb4179f2f

  1. bug 1790762

[@ nsCOMPtr<T>::get | nsCOMPtr<T>::operator nsIPrincipal* | mozilla::dom::ServiceWorkerInfo::Principal]
e.g. bp-22e85bee-3fcb-43e7-b473-a489e0220914
27 crashes from 21 installations.

Status: RESOLVED → REOPENED
Crash Signature: [@ nsCOMPtr<T>::get | nsCOMPtr<T>::operator nsIPrincipal* | mozilla::dom::ServiceWorkerInfo::Principal]
Flags: needinfo?(echuang)
Resolution: FIXED → ---
Target Milestone: 106 Branch → ---
Backout by abutkovits@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/a3b25b7bf192
Backed out 4 changesets for frequent autoland crashes. CLOSED TREE
Crash Signature: [@ nsCOMPtr<T>::get | nsCOMPtr<T>::operator nsIPrincipal* | mozilla::dom::ServiceWorkerInfo::Principal] → [@ nsCOMPtr<T>::get | nsCOMPtr<T>::operator nsIPrincipal* | mozilla::dom::ServiceWorkerInfo::Principal] [@ nsCOMPtr<T>::get | nsCOMPtr<T>::operator nsIPrincipal* const | mozilla::dom::ServiceWorkerInfo::Principal]

The bug is linked to a topcrash signature, which matches the following criterion:

  • Top 10 desktop browser crashes on nightly

:edenchuang, could you consider increasing the severity of this top-crash bug?

For more information, please visit auto_nag documentation.

Flags: needinfo?(echuang)
Keywords: topcrash

The crashes are caused by the backed-out patch. So we don't consider increasing the severity of it.

Flags: needinfo?(echuang)

Based on the topcrash criteria, the crash signatures linked to this bug are not in the topcrash signatures anymore.

For more information, please visit auto_nag documentation.

Keywords: topcrash
Pushed by echuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/825277ae13f4
Remove ServiceWorkerRegistration::Inner r=asuth
https://hg.mozilla.org/integration/autoland/rev/57af4021e491
Remove ServiceWorkerContainer::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/7b1656140268
Remove ServiceWorker::Inner r=dom-worker-reviewers,asuth
https://hg.mozilla.org/integration/autoland/rev/94fbc4e4411b
Remove ServiceWorkerPrivate::Inner r=asuth,dom-worker-reviewers
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: