Open Bug 1715572 Opened 1 year ago Updated 6 days ago

[Prompts] Select prompts should be dismissed when user clicks other fields

Categories

(GeckoView :: General, enhancement, P1)

Unspecified
All
enhancement

Tracking

(firefox-esr91 wontfix, firefox100 wontfix, firefox101 wontfix, firefox102 wontfix, firefox103 fixed)

ASSIGNED
103 Branch
Tracking Status
firefox-esr91 --- wontfix
firefox100 --- wontfix
firefox101 --- wontfix
firefox102 --- wontfix
firefox103 --- fixed

People

(Reporter: petru, Assigned: m_kato)

References

(Regressed 1 open bug)

Details

(Keywords: leave-open, Whiteboard: [geckoview:m94?] [geckoview:m102] [geckoview:m103])

Attachments

(3 files)

Needed for https://github.com/mozilla-mobile/fenix/issues/19707

We currently have the onLoginSelect and onCreditCardSelect prompts which will be triggered whenever the user clicks on a field that can be autocompleted with that type of data.

But these prompts will stay on the screen (at the bottom) until they are consumed by the user picking an item to be autocompleted.

I propose a similar API, maybe something like onCancelLoginSelect and onCancelCreditCardSelect for when the user clicks in another field / another part of the page which cannot be autocompleted with the data from that prompt.
And then, when the user clicks again in a credit card / login field for the prompt to be re-requested.

I think this would lead to a similar UX as on desktop.

Severity: -- → S3
Depends on: 1710668
Flags: needinfo?(petru.lingurar)
Priority: -- → P2
Whiteboard: [geckoview:m93?]
Flags: needinfo?(petru.lingurar)
Whiteboard: [geckoview:m93?] → [geckoview:m94?]

FWIW I don't think we need a new API for this, onPromptDismiss is already present in PromptInstanceDelegate which all promps have: https://searchfox.org/mozilla-central/source/mobile/android/geckoview/src/main/java/org/mozilla/geckoview/GeckoSession.java#3744

we just need to call dismiss on the prompt when we navigate away on the JS side.

Assigning to m_kato who was assigned to the duplicate.

Assignee: nobody → m_kato
Keywords: leave-open

Bumping priority to P1 since Makoto is working on this bug.

Keywords: leave-open
Priority: P2 → P1
Whiteboard: [geckoview:m94?] → [geckoview:m94?] [geckoview:m102]
Attachment #9277485 - Attachment description: Bug 1715572 - onPromptDismiss should be callded when losting focus by content script. r=#geckoview-reviewers → Bug 1715572 - Choice prompt should be dismissed when focus is lost by content script. r=#geckoview-reviewers

We need to handle FormAutoComplete:ClosePopup to dismiss autocomplete pop up.

When we add some tests for autocomplete, it may cause test failure due to test
order. Pop up is opened before using fetched data. So I add a workaround to
remove previous credit card and address information for some tests.

Depends on D147054

Carrying forward to 103. Agi says this fix will be too complex to uplift to Beta 102.

Whiteboard: [geckoview:m94?] [geckoview:m102] → [geckoview:m94?] [geckoview:m102] [geckoview:m103]
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/0f2d85a32350
Choice prompt should be dismissed when focus is lost by content script. r=geckoview-reviewers,agi
Status: NEW → RESOLVED
Closed: 29 days ago
Resolution: --- → FIXED
Target Milestone: --- → 103 Branch

This bug has leave-open keyword

Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Status: REOPENED → ASSIGNED
Keywords: leave-open
Regressions: 1771945
Pushed by m_kato@ga2.so-net.ne.jp:
https://hg.mozilla.org/integration/autoland/rev/6a1a61daa78f
DateTime prompt should be dismissed when focus is lost by content script. r=geckoview-reviewers,agi
Depends on: 1776138
You need to log in before you can comment on or make changes to this bug.