Closed Bug 1716300 Opened 2 years ago Closed 2 years ago

Use of unknown property Ci.mozIExtensionAPIRequestResult.RESULT_VALUE in test_ext_webidl_runtime_port.js

Categories

(WebExtensions :: General, defect, P1)

defect

Tracking

(firefox-esr78 unaffected, firefox89 unaffected, firefox90 unaffected, firefox91 fixed)

RESOLVED FIXED
91 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox89 --- unaffected
firefox90 --- unaffected
firefox91 --- fixed

People

(Reporter: standard8, Assigned: rpl)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

Bug 1682632 added test_ext_webidl_runtime_port.js, we have a manually (at the moment) run eslint rule that has picked up the following:

toolkit/components/extensions/test/xpcshell/webidl-api/test_ext_webidl_runtime_port.js
  95:19  error  Use of unknown property Ci.mozIExtensionAPIRequestResult.RESULT_VALUE  mozilla/ci-checks (eslint)
Flags: needinfo?(lgreco)
Assignee: nobody → lgreco
Status: NEW → ASSIGNED

Ci.mozIExtensionAPIRequestResult.RESULT_VALUE was actually meant to be Ci.mozIExtensionAPIRequestResult.RETURN_VALUE (which is the enum actually defined in the idl file as a cenum).

It used to be named RESULT_VALUE in a older version of those patches, I missed to notice it because that part of the test is expected to trigger an error, returning the unknown RESULT_VALUE does still trigger the error but it was meant to trigger the error because the value returned doesn't contain the property expected by a (ExtensionPortDescription webIDL dictionary)[https://searchfox.org/mozilla-central/rev/bea2345ce636dc329ac7133fc0a13c9171777e40/dom/webidl/ExtensionPort.webidl#36-39].

The attached patch fixed the typo, and I have verified locally that the test still pass as expected.

Flags: needinfo?(lgreco)

Set release status flags based on info from the regressing bug 1682632

Severity: -- → S4
Priority: -- → P1
Pushed by luca.greco@alcacoop.it:
https://hg.mozilla.org/integration/autoland/rev/f3ad535e2c9f
Fix Ci.mozIExtensionAPIRequestResult cenum value typo in test_ext_webidl_runtime_port.js. r=mixedpuppy
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch
Has Regression Range: --- → yes
You need to log in before you can comment on or make changes to this bug.