Closed Bug 1716680 Opened 1 year ago Closed 1 year ago

Syncing calendars doesn't update views until they change

Categories

(Calendar :: Calendar Frontend, defect)

defect

Tracking

(thunderbird_esr78 unaffected)

RESOLVED FIXED
91 Branch
Tracking Status
thunderbird_esr78 --- unaffected

People

(Reporter: darktrojan, Assigned: darktrojan)

References

(Regression)

Details

Attachments

(3 files)

I've broken the views. When a calendar sync happens, the views aren't updated with any new events or changes that happened on the server. [Not really] unbelievably there are no tests for this, so I'll be fixing that.

In this patch we'll use notifications that come from real calendars and ignore notifications that come from the composite calendar. I'm not sure there's supposed to be notifications from both, but there are.

The composite calendar also won't pass on onLoad notifications if it is itself loading. That's not bad for apparent performance and is also the cause of this bug. I've changed that behaviour.

Just a tidy-up to make the next patch easier.

Depends on D118149

This test synchronises with the remote calendar three times. An event is added the first time and should appear. It's modified the second time and should be updated. It's deleted the third time and should disappear.

Depends on D118150

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/04ddd7d0ac06
Stop squashing onLoad notifications in the composite calendar. r=mkmelin
https://hg.mozilla.org/comm-central/rev/b068a0f0cca6
Reorganise calendar provider mochitests. r=mkmelin
https://hg.mozilla.org/comm-central/rev/fe4a715baffb
Test that synchronising calendars updates the views. r=mkmelin

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

I may have been stumbling over this with caldav calendars. I could not consistently reproduce this behavior so did not bother to file a bug. I created an event on the server, deleted it, then created another one. The second one did not appear until restart, this did not happen all the time. I do wonder if this was the cause? Maybe bug 1684359 too?

You need to log in before you can comment on or make changes to this bug.