Crash after installing the UAbar

VERIFIED DUPLICATE of bug 171333

Status

()

--
critical
VERIFIED DUPLICATE of bug 171333
16 years ago
16 years ago

People

(Reporter: torben, Assigned: asa)

Tracking

({crash})

Trunk
x86
Windows 95
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20020929
Build Identifier: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.2b) Gecko/20020929

If I install the UAbar from http://uabar.mozdev.org/source.html Mozilla will
crash when opening new window or after restart.

Reproducible: Always

Steps to Reproduce:
1.Go to http://uabar.mozdev.org/source.html
2.Install the UAbar.
3.Open new window or restart Mozilla

Actual Results:  
Mozilla crashes.

Expected Results:  
No crash.

Talkback ID TB11794430W
UAbar worked with the last build I tried (probably 20020923xx). If time allows I
will investigate when this was broken tomorrow.
(Reporter)

Comment 1

16 years ago
Got some time today: UAbar works with build 2002092308, can't test with builds
2002092408-2002062808 since they all fail to load (anyone knows which bug that
was?), crash as described with 2002092908

Comment 2

16 years ago
related: bug 171333.
Keywords: crash, stackwanted
Whiteboard: TB11794430W
(Reporter)

Comment 3

16 years ago
Yes, probably a dupe of bug 171333 (why didn't that show up in my searches?),
UAbar works with build 2002093004.

*** This bug has been marked as a duplicate of 171333 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 4

16 years ago
Verified dupe of bug 171333.

Incident #11794430
--------------------
Product ID  MozillaTrunk
Build ID 2002092908
Operating System Windows 95 4.0 build 67109975
User Comments installing uabar

Stack Trace
nsFileChannel::GetFile
[c:/builds/seamonkey/mozilla/netwerk/protocol/file/src/nsFileChannel.cpp, line 729]
nsChromeProtocolHandler::NewChannel
[c:/builds/seamonkey/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp, line 738]
nsIOService::NewChannelFromURI
[c:/builds/seamonkey/mozilla/netwerk/base/src/nsIOService.cpp, line 513]
NS_NewChannel [../../../../dist/include/necko\nsNetUtil.h, line 165]
NS_OpenURI [../../../../dist/include/necko\nsNetUtil.h, line 227]
nsXULDocument::ResumeWalk
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 5728]
nsXULDocument::CachedChromeStreamListener::OnStopRequest
[c:/builds/seamonkey/mozilla/content/xul/document/src/nsXULDocument.cpp, line 7027]
nsDocumentOpenInfo::OnStopRequest
[c:/builds/seamonkey/mozilla/uriloader/base/nsURILoader.cpp, line 257]
nsCachedChromeChannel::HandleStopLoadEvent
[c:/builds/seamonkey/mozilla/rdf/chrome/src/nsChromeProtocolHandler.cpp, line 472]
PL_HandleEvent [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line 647]
PL_ProcessPendingEvents [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c,
line 580]
_md_EventReceiverProc [c:/builds/seamonkey/mozilla/xpcom/threads/plevent.c, line
1330]
KERNEL32.DLL + 0x22894 (0xbff92894)
0x00648b64 
Status: RESOLVED → VERIFIED
Keywords: stackwanted
Whiteboard: TB11794430W

Updated

16 years ago
Component: Browser-General → Networking: File
You need to log in before you can comment on or make changes to this bug.