Closed Bug 1716917 Opened 3 months ago Closed 3 months ago

Javascript decimal math errors

Categories

(Firefox :: Untriaged, defect)

Firefox 89
defect

Tracking

()

RESOLVED DUPLICATE of bug 5856

People

(Reporter: qwerty_kidd, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:89.0) Gecko/20100101 Firefox/89.0

Steps to reproduce:

Entering even something as simple as "1.1-1" into the console.

Actual results:

Result for me in 89.0.1 (and 88.x.x) x64 on Win10 is "0.10000000000000009".

Expected results:

Obviously, the result of the above example should be "0.1"

Attachment #9227582 - Attachment description: Screenshot 2021-06-16 224628.png → Examples of intermittent errors in decimal math.
Attachment #9227582 - Attachment filename: Screenshot 2021-06-16 224628.png → JS_math_bug.png
Status: UNCONFIRMED → RESOLVED
Closed: 3 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: js-ieee-double-hurts
You need to log in before you can comment on or make changes to this bug.