Closed Bug 1717169 Opened 6 months ago Closed 6 months ago

Collect value of browser.urlbar.showSearchSuggestionsFirst

Categories

(Firefox :: Address Bar, enhancement, P3)

enhancement

Tracking

()

RESOLVED FIXED
91 Branch
Tracking Status
firefox90 --- fixed
firefox91 --- fixed

People

(Reporter: tdsmith, Assigned: tdsmith)

Details

Attachments

(2 files)

We're interested in understanding how many clients have a non-default value for the browser.urlbar.showSearchSuggestionsFirst preference. We used it for targeting in https://experimenter.services.mozilla.com/nimbus/firefox-suggest-v1 and enrollment is somewhat lower than we expected and we think this might be one reason why, and we'd like to confirm or reject that idea.

Attachment #9227824 - Flags: data-review?(tlong)

Comment on attachment 9227824 [details]
Data collection request

Data Review

  1. Is there or will there be documentation that describes the schema for the ultimate data set in a public, complete, and accurate way?

Yes, via the TelemetryEnvironment.jsm

  1. Is there a control mechanism that allows the user to turn the data collection on and off?

Yes, normal telemetry opt-out in preferences.

  1. If the request is for permanent data collection, is there someone who will monitor the data over time?

Rebecca BurWei to be responsible for monitoring the permanent collection of this metric.

  1. Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 2, User Interaction

  1. Is the data collection request for default-on or default-off?

default-on

  1. Does the instrumentation include the addition of any new identifiers (whether anonymous or otherwise; e.g., username, random IDs, etc. See the appendix for more details)?

No

  1. Is the data collection covered by the existing Firefox privacy notice?

Yes

  1. Does the data collection use a third-party collection tool?

No

Result

data-review+

Attachment #9227824 - Flags: data-review?(tlong) → data-review+
Pushed by tismith@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b0f81b8214e5
Collect value of browser.urlbar.showSearchSuggestionsFirst r=chutten
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 91 Branch

Comment on attachment 9227823 [details]
Bug 1717169 - Collect value of browser.urlbar.showSearchSuggestionsFirst r=chutten

Beta/Release Uplift Approval Request

  • User impact if declined: This is a telemetry-only change so there's no direct user impact, but we're interested in understanding whether enrollment is lower than expected in https://experimenter.services.mozilla.com/nimbus/firefox-suggest-v1 because more users than we expected have changed this preference.
    Having this context sooner will help us execute the follow-up experiments that are planned for upcoming releases.
  • Is this code covered by automated tests?: Yes
  • Has the fix been verified in Nightly?: No
  • Needs manual test from QE?: No
  • If yes, steps to reproduce:
  • List of other uplifts needed: None
  • Risk to taking this patch: Low
  • Why is the change risky/not risky? (and alternatives if risky): One-line change that extends a list of prefs to collect using a well-tested telemetry mechanism; doesn't introduce or change any logic.
  • String changes made/needed: none
Attachment #9227823 - Flags: approval-mozilla-release?
Attachment #9227823 - Flags: approval-mozilla-beta?

Comment on attachment 9227823 [details]
Bug 1717169 - Collect value of browser.urlbar.showSearchSuggestionsFirst r=chutten

approved for 90.0b12.

at this point if we have another 89 dot release it'd be a chemspill, though, so a- for release.

Attachment #9227823 - Flags: approval-mozilla-release?
Attachment #9227823 - Flags: approval-mozilla-release-
Attachment #9227823 - Flags: approval-mozilla-beta?
Attachment #9227823 - Flags: approval-mozilla-beta+

Thanks, Julien!

You need to log in before you can comment on or make changes to this bug.