Closed Bug 171895 Opened 22 years ago Closed 22 years ago

Images not loaded when inside element with display:none;

Categories

(Core :: Graphics: ImageLib, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 83774

People

(Reporter: bugzilla, Assigned: pavlov)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020929
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20020929

The testcase contains a Table with a TR that has display:none;. Clicking on
"Expand" will show the TR. You will notice that the images inside that element
will start to load. Should'nt these images be loaded when the document loads?

See attached testcase. Empty your cache to see it again.

Reproducible: Always

Steps to Reproduce:


Actual Results:  
Images are loaded when display property is changed

Expected Results:  
Load the images when the document loads.
Attached file Testcase
The Question here is: Bug or feature :-)? In the specs there stands nothing what
to do in such a case. On the one hand you could say there stands "display:none",
not "load:none". But on the other hand, it would make more sense if it isn't
loaded (someone wants to hide parts of his page per CSS, then it wouldn't make
much sense to load them).
Yeah, that is the question.
IE loads all the images while loading the document.

My 2 cents is that they should be loaded, otherwise what, you have to preload 
all the images that are hidden to avoid this?
caillon, don't we already have a bug on this?  I could have sworn we did...
Whiteboard: DUPEME
Boris, do you mean bug 83774?
Yep

*** This bug has been marked as a duplicate of 83774 ***
Status: UNCONFIRMED → RESOLVED
Closed: 22 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: