Viewing msg with multiple attachments, last attachment text cropped

RESOLVED EXPIRED

Status

SeaMonkey
MailNews: Message Display
RESOLVED EXPIRED
15 years ago
4 years ago

People

(Reporter: jglick, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
View a msg with 3 or more attachments.

1. 3 attachments, bottom of last attachment being cropped. Should display a
scrollbar if necessary, so user can scroll and see entire attachment. See first
screenshot below for example.

2. 4 attachments, a scroll bar is available, but you can't scroll far enough
down to see bottom of last attachment. See 2nd screenshot below for example.

Comment 1

15 years ago
I think we've got a bug about this already, will try to locate it. Clears on
revisting folder or restart, I believe.
Whiteboard: DUPEME
(Reporter)

Comment 2

15 years ago
*** Bug 172033 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 3

15 years ago
Thanks Laurel. Screenshots are in dup bug 172033, if its useful.

Comment 4

15 years ago
The bug I was thinking of is bug 122180 - originally reported as just Classic on
 Mac, but other comments indicate all platforms and also Modern.
(Reporter)

Comment 5

15 years ago
From bug 122180:

>Find a message with 3 or more attachments, and click it.
>What happens: the "Attachments:" box shows two attachments (the bottom of the
>second cut off) with no scroll bar.
>What should happen: a scroll bar should appear so that one can scroll down to
>see the third attachment.

I am getting the scrollbar correctly, but the bottom attachment in each case is
being cropped. So, sorta related?

Comment 6

15 years ago
I have this problem with Mac OS X build 2003030803 too, with the additional
problem that if you scroll through the attachment list using the down arrow key,
the display gets screwed up and the first attachment appears blank.

Contrary to Comment 1, restarting does not clear up the problem; it happens
every time.
OS: Windows 2000 → All
Hardware: PC → All

Comment 7

15 years ago
Created attachment 116644 [details]
screen shot of problem

Here is a screen shot of the problem described in comment 6. The message has
attachments test1.txt, test2.txt, test3.txt, and test4.txt. The screen shot
shows what you get when you use down arrow key to select test4.txt. You can't
see test4.txt, and test1.txt disappears. Build 2003030803 on Mac OS X 10.2.4
with Classic theme.

Comment 8

14 years ago
I have users getting this behaviour with win9x and win2k client mozilla 1.6
Gecko/20040113.

In the "full" message window, the scroll bar for the attachments combo box is
not available, so that only 3 attachments are visible (disaster has struck once
as a result of this).  In the preview window, the scroll bar is visible, but the
last attachment doesn't show up.

Rebooting has no effect, and it shows up upon first invocation of the program.

Thunderbird 0.5 on the same machines with the same mail file does not exhibit
this behavior.

Comment 9

14 years ago
In the message window: View - Headers - Normal or All resets the attachment
window to correct function. It's a workaround for the problem. Hope this helps
in resolving it completely....

Comment 10

14 years ago
I can confirm that this problem exists in 1.5,1.6 and 1.7rc1.  We have users who
are extremely upset with this, as the "last attachment text cropped" description
does not do it justice.  The last attachment in the list is COMPLETELY
UNAVAILABLE.  The user can't see it, can't select it, can't save it, doesn't
even know it's there.  The number of the attachments is, but the user only sees 4.

There may be workarounds, but the user has no idea that he needs to use them.

I would consider this a critical flaw in the the mail handling system.

Comment 11

14 years ago
I have confirmed this on Mozilla 1.6 on Windows 2000 -- but when the user
forwarded the message in question to me, I was able to see all the attachments
in the list in the forwarded message (running 1.7 on WinXPsp1). So I downloaded
 Moz1.6 and ran it locally (using the same profile I used with 1.7) and lo and
behold! The last attachment in the forwaded message was now missing (but like
the original user, a 'save all' DOES save the missing attachment with the others).

I then downloaded and lauched moz1.7.2 in the same session that the user
originally had problems with (using 1.6); and sure enough, she was then able to
see the final attachemnt.

So, it looks like this was fixed in 1.7 -- can anyone confirm? It's kinda odd,
'cuz this thread gives no indication that this was fixed, so its possible this
is a dupe, no?
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
Assignee: mail → nobody
QA Contact: olgam → message-display

Comment 12

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 13

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 14

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 15

8 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → EXPIRED

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.