Closed Bug 1720553 Opened 1 year ago Closed 11 months ago

[wpt-sync] Sync PR 29665 - Deflake playing-an-animation.html

Categories

(Core :: DOM: Animation, task, P4)

task

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox92 --- fixed

People

(Reporter: mozilla.org, Unassigned)

References

()

Details

(Whiteboard: [wptsync downstream])

Sync web-platform-tests PR 29665 into mozilla-central (this bug is closed when the sync is complete).

PR: https://github.com/web-platform-tests/wpt/pull/29665
Details from upstream follow.

b'Xida Chen <xidachen@chromium.org>' wrote:

Deflake playing-an-animation.html

The root cause of the flakiness seems to be a floating point
precision issue. This CL fixed it by introducing an epsilon.

Without this fix, I can repro the flakiness locally very easily.
With this fix, I have ran 1000 times with running 48 content
shell in parallel and there is no flake.

Bug: 1198515
Change-Id: I6eaddebe12bba5131ee340549f84b7b27b729c37

Reviewed-on: https://chromium-review.googlesource.com/3027227
WPT-Export-Revision: 6114e6aa96edfdac11d9de7ab81bd9ef5570bc1b

Component: web-platform-tests → DOM: Animation
Product: Testing → Core

CI Results

Ran 10 Firefox configurations based on mozilla-central, and Firefox, Chrome, and Safari on GitHub CI

Total 1 tests and 12 subtests

Status Summary

Firefox

OK : 1
PASS: 12

Chrome

OK : 1
PASS: 12

Safari

OK : 1
PASS: 12

Links

Gecko CI (Treeherder)
GitHub PR Head
GitHub PR Base

Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6b5bf1848875
[wpt PR 29665] - Deflake playing-an-animation.html, a=testonly
Pushed by wptsync@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/56c02e5f7e6a
[wpt PR 29665] - Deflake playing-an-animation.html, a=testonly
Status: NEW → RESOLVED
Closed: 11 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.