Closed Bug 1720714 Opened 2 months ago Closed 2 months ago

Crash in [@ mozilla::ipc::PortLink::SendMessage]

Categories

(Core :: IPC, defect)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1718333

People

(Reporter: sefeng, Unassigned)

Details

(Keywords: crash)

Crash Data

Maybe Fission related. (DOMFissionEnabled=1)

Crash report: https://crash-stats.mozilla.org/report/index/6902fcb0-8a9f-4b16-a3dc-179c70210713

MOZ_CRASH Reason: MOZ_RELEASE_ASSERT(mWorkerThread && !mWorkerThread->IsOnCurrentThread()) (on worker thread but should not be!)

Top 10 frames of crashing thread:

0 XUL mozilla::ipc::PortLink::SendMessage ipc/glue/MessageLink.cpp:127
1 XUL mozilla::ipc::NodeController::OnEventMessage ipc/glue/NodeController.cpp:355
2 XUL mojo::core::ports::Node::AcceptEvent ipc/chromium/src/mojo/core/ports/node.cc:419
3 XUL mozilla::ipc::NodeController::PortStatusChanged ipc/glue/NodeController.cpp:347
4 XUL mojo::core::ports::Node::AcceptEvent ipc/chromium/src/mojo/core/ports/node.cc:417
5 XUL XUL@0x92983e 
6 XUL mozilla::ipc::MessageChannel::Send ipc/glue/MessageChannel.cpp:905
7 XUL mojo::core::ports::Node::CreateUninitializedPort ipc/chromium/src/mojo/core/ports/node.cc:131
8 XUL mozilla::dom::PContentParent::SendRegisterChrome ipc/ipdl/PContentParent.cpp:2241
9 XUL mozilla::dom::ContentParent::~ContentParent dom/ipc/ContentParent.cpp:2809
Severity: -- → S2
Status: NEW → RESOLVED
Closed: 2 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1718333
Component: DOM: Content Processes → IPC
You need to log in before you can comment on or make changes to this bug.