Closed Bug 1720869 Opened 5 months ago Closed 4 months ago

Add telemetry probe for referrer policy

Categories

(Core :: Privacy: Anti-Tracking, task)

task

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox92 --- fixed

People

(Reporter: timhuang, Assigned: timhuang)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Add telemetry probe for the count of each referrer policy.

Attached file data-request.md
Attachment #9231622 - Flags: data-review?(chutten)

Comment on attachment 9231622 [details]
data-request.md

PRELIMINARY NOTE: This review assumes the collection selects referer policies from a known list and doesn't collect arbitrary strings. If you are collecting arbitrary strings, please resubmit the data collection review as it would be Category 3 data (stored content/communications).

DATA COLLECTION REVIEW RESPONSE:

Is there or will there be documentation that describes the schema for the ultimate data set available publicly, complete and accurate?

Yes.

Is there a control mechanism that allows the user to turn the data collection on and off?

Yes. This collection is Telemetry so can be controlled through Firefox's Preferences.

If the request is for permanent data collection, is there someone who will monitor the data over time?

Yes, Tim Huang is responsible.

Using the category system of data types on the Mozilla wiki, what collection type of data do the requested measurements fall under?

Category 1, Technical.

Is the data collection request for default-on or default-off?

Default on for all channels.

Does the instrumentation include the addition of any new identifiers?

No.

Is the data collection covered by the existing Firefox privacy notice?

Yes.

Does the data collection use a third-party collection tool?

No.


Result: datareview+

Attachment #9231622 - Flags: data-review?(chutten) → data-review+
Duplicate of this bug: 1720684
Pushed by tihuang@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a50b620bc947
Part 1: Add a telemetry probe for referrer policy. r=ckerschb,necko-reviewers,valentin
https://hg.mozilla.org/integration/autoland/rev/b383b1d08f02
Part 2: Add a test browser_referrer_telemetry.js to test referrer policy telemetry probe. r=ckerschb
Status: ASSIGNED → RESOLVED
Closed: 4 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.