Prefs UI: Remove offline news features

VERIFIED FIXED in M17

Status

SeaMonkey
MailNews: Message Display
P2
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: laurel, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/01])

(Reporter)

Description

18 years ago
The Disk Space prefs pertaining to news messages are generally not sticking in
the prefs UI.  A couple types of changes will indeed stick, but it appears only
the toggling of "keep only unread messages" will truly write to the prefs.js
file.

Note:  after migrating 4.x profile, the news.keep.<various prefs> pref lines are
present in 5.0 prefs.js with the same values as 4.x.

1.  Launch seamonkey/5.0 to messenger.
2.  Edit|Prefs|Mail&News|Disk Space.
    Make changes to the prefs in Newsgroup Messages Only section.
    Confirm OK.
3.  Check the prefs dialog again -- result: most of the prefs changes don't
stick.
4.  Check the prefs.js file and see the changes were not written to the prefs.js
file (Exception being news.keep.only_unread).
(Reporter)

Updated

18 years ago
QA Contact: lchiang → huang
accepting.

Updated

18 years ago
Target Milestone: M14
Priority: P3 → P2
marking p2

Comment 3

18 years ago
Since offline news is cut for seamonkey, I"m just marking this a dup of the
other offline news prefs bug.


*** This bug has been marked as a duplicate of 17104 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 4

18 years ago
ok, mark as verified.
Status: RESOLVED → VERIFIED

Comment 5

18 years ago
Reopen this bug based on the last comments of the bug#17104 from Laurel & Phil.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 6

18 years ago
Per Phil: Offline news is uncommitted for Seamonkey. Let's just remove the 
prefs.
Summary: Prefs UI: News Disk Space prefs not sticking → Prefs UI: Remove offline news features
moving to m15.
Target Milestone: M14 → M15
moving to m16.
Target Milestone: M15 → M16

Comment 9

18 years ago
Got a lot of beta1 feedback about how confusing this was.  Need to remove the 
bogus UI.  Marking nsbeta2.
Keywords: nsbeta2

Comment 10

18 years ago
Mass moving M16 to M17 - look for nsbeta2 before anything else.
Target Milestone: M16 → M17

Comment 11

18 years ago
Putting on [nsbeta2+][6/01] radar.  Please pull this out by 6/01.
Whiteboard: [nsbeta2+][6/01]
fixed.  thanks to laurel for helping me figure this all out.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Updated

18 years ago
Blocks: 26057
(Reporter)

Comment 13

18 years ago
OK using 2000-06-01-08 commercial build linux rh6.0, NT 4.0, mac OS 9.0
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.