Closed Bug 1721946 Opened 1 year ago Closed 1 year ago

vCardToAbCard incorrectly handles multiple values in name components

Categories

(MailNews Core :: Address Book, defect)

defect

Tracking

(thunderbird91 fixed)

RESOLVED FIXED
92 Branch
Tracking Status
thunderbird91 --- fixed

People

(Reporter: darktrojan, Assigned: darktrojan)

References

Details

Attachments

(1 file)

From RFC6350:

The text components are separated by the SEMICOLON character (U+003B). Individual text components can include multiple text values separated by the COMMA character (U+002C).

The parser correctly reads multiple values separated by a comma into an array of values, but we need a string.

Target Milestone: --- → 92 Branch

Pushed by geoff@darktrojan.net:
https://hg.mozilla.org/comm-central/rev/5e78571e7056
Read multiple name values correctly when converting from VCard. r=rnons

Status: ASSIGNED → RESOLVED
Closed: 1 year ago
Resolution: --- → FIXED

Comment on attachment 9232766 [details]
Bug 1721946 - Read multiple name values correctly when converting from VCard. r=rnons

[Approval Request Comment]
Regression caused by (bug #):
User impact if declined: faulty parsing of vCards, very minor, very unlikely
Testing completed (on c-c, etc.): landed last week
Risk to taking this patch (and alternatives if risky): low

Attachment #9232766 - Flags: approval-comm-beta?

Comment on attachment 9232766 [details]
Bug 1721946 - Read multiple name values correctly when converting from VCard. r=rnons

[Triage Comment]
Approved for beta

Attachment #9232766 - Flags: approval-comm-beta? → approval-comm-beta+
You need to log in before you can comment on or make changes to this bug.