Closed Bug 1722231 Opened 2 months ago Closed 2 months ago

Permanent xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_cookieStoreId.js | Test timed out when Gecko 92 merges to Beta on 2021-08-09

Categories

(WebExtensions :: General, defect, P1)

defect

Tracking

(firefox-esr78 unaffected, firefox90 unaffected, firefox91 unaffected, firefox92+ verified)

VERIFIED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 + verified

People

(Reporter: cbrindusan, Assigned: karim, NeedInfo)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

  • central-as-beta simulation
  • How to run these simulations
  • Failure log
    [task 2021-07-25T12:35:18.140Z] 12:35:18 INFO - TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_cookieStoreId.js
    [task 2021-07-25T12:40:18.171Z] 12:40:18 WARNING - TEST-UNEXPECTED-TIMEOUT | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_cookieStoreId.js | Test timed out
Flags: needinfo?(kanishk509)

Hey,

Looks like my test caused this. The issue is that containers are disabled by default outside of Nightly, but the tests require containers: as per the failure log, CONSOLE_MESSAGE: (error) [JavaScript Error: "Error: Contextual identities are currently disabled" {file: "undefined" line: 0}]. I'll push a revision to fix this test.

Thanks!

Assignee: nobody → karim
Status: NEW → ASSIGNED
Pushed by rob@robwu.nl:
https://hg.mozilla.org/integration/autoland/rev/95a48d0ce71e
Enable containers in test_ext_downloads_cookieStoreId unit test. r=robwu
Duplicate of this bug: 1722255
Severity: -- → S4
Priority: -- → P1
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.