Open Bug 1722567 Opened 4 months ago Updated 2 months ago

Multiple tabs undo close not consistent

Categories

(Firefox :: Tabbed Browser, defect)

Firefox 91
defect

Tracking

()

REOPENED
94 Branch
Tracking Status
firefox90 --- wontfix
firefox91 --- wontfix
firefox92 --- wontfix
firefox93 --- wontfix
firefox94 --- fixed

People

(Reporter: pyjacpp, Assigned: pyjacpp)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:91.0) Gecko/20100101 Firefox/91.0

Steps to reproduce:

Open some tabs
Close 4 tabs (grouped)
Close 1 tab
Reopen closed tabs

Actual results:

The last 4 tabs reopen.
Do "reopen closed tabs" to reopen the first tab.

Expected results:

The last tab should be restored alone, then if "reopen closed tabs" is do again, it should restore all 4 tabs.

Summary: Multiple tabs undo close → Multiple tabs undo close not consistent

The Bugbug bot thinks this bug should belong to the 'Firefox::Tabbed Browser' component, and is moving the bug to that component. Please revert this change in case you think the bot is wrong.

Component: Untriaged → Tabbed Browser

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:90.0) Gecko/20100101 Firefox/90.0

Hi,

I am able to reproduce the issue in release 90.0.2, beta 91.0b7 and latest nightly 92.0a1 (2021-07-28) using Windows 10.

Thanks for your input.

Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Unspecified → All
Hardware: Unspecified → All
Blocks: 1722727

When a group of tabs is closed, save the it in session data so tabs could be restored together.

Assignee: nobody → pyjacpp
Status: NEW → ASSIGNED
Pushed by kmadan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6aaaf18f2aae
Save group of closed tabs to restore the all group. r=kashav

Backed out changeset 6aaaf18f2aae (Bug 1722567) for causing bc failures in browser_forget_async_closings.js
Backout link: https://hg.mozilla.org/integration/autoland/rev/943a0020922197ac932b3f1823f5f4299970ae87
Push with failures, failure log.

Flags: needinfo?(pyjacpp)

Thanks I will investigate.

Flags: needinfo?(pyjacpp)
Attachment #9233551 - Attachment description: Bug 1722567 - Save group of closed tabs to restore the all group. r=Gijs → Bug 1722567 - Save group of closed tabs to restore the all group. r=kashav
Pushed by kmadan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/b911ae170ab6
Save group of closed tabs to restore the all group. r=kashav
Backout by ccozmuta@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/3926e1cff232
Backed out changeset b911ae170ab6 for causing failures on browser_frame_history.js. CLOSED TREE

Thanks I will investigate.

Flags: needinfo?(pyjacpp)
Pushed by kmadan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/06634a58a08a
Save group of closed tabs to restore the all group. r=kashav
Status: ASSIGNED → RESOLVED
Closed: 3 months ago
Resolution: --- → FIXED
Target Milestone: --- → 94 Branch

Since the status are different for nightly and release, what's the status for beta?
For more information, please visit auto_nag documentation.

Flags: qe-verify+

I was able to reproduce the issue on release 90.0.2.

On latest Beta 94.0b2 and Nightly 95.0a1 on Win10&Ubuntu20.4 issue is partially fixed, meaning:

  1. Close 4tabs and than 1tab.

  2. Press to reopen closed tab first time:
    Actual/Expected result: Only one tab is reopened.

  3. Press to reopen closed tab second time:
    Actual result: Only one tab is reopened.
    Expected result: All 4 tabs previously closed should be opened.

Reopen issue based on about description.

Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Yes, you are right, but in phabricator we decided to not do this part and only handle the last group closed, so it's fixes the inconsistent part and will either reopen an exact group of tabs or if it was a group but other tabs were closed after, it will reopen tabs one by one. What should we do with this bug, should we keep it open or should we close it?

You need to log in before you can comment on or make changes to this bug.