Closed Bug 1722864 Opened 6 months ago Closed 6 months ago

[MSIX] No icon for Firefox is created on the desktop after installing Firefox

Categories

(Firefox :: Installer, defect)

Firefox 92
Desktop
Windows
defect

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox92 --- affected

People

(Reporter: csasca, Unassigned)

References

(Blocks 2 open bugs)

Details

Affected versions

  • 92.0a1 (2021-07-28) MSIX installer

Affected platforms

  • Windows 11

Steps to reproduce

  1. Install MSIX build

Expected result

  • An icon for Firefox is created on the desktop

Actual result

  • No icon for Firefox is created on the desktop

Regression range

  • Not a regression, msix package affected

Additional notes

  • Only msix package seems to be affected, installing a regular Nightly build will create a desktop icon
Has STR: --- → yes

I think this is just the new world order: see this reddit comment. I'm inclined to trust this user since they appear knowledgable and claim to be VP product at Advanced Installer. The same user says in this comment: "MSIX packages can only create application entry points (what you previously knew as shortcuts) only in the start menu. You can't create them on your desktop or any other folder."

My searching suggests that this is just the way things are now, so I'm going to NI :mhowell to confirm and let her close this as WONTFIX.

Thanks for the initial bug reports, Catalin -- much appreciated!

Flags: needinfo?(mhowell)

I agree with Nick; MSIX doesn't support creating desktop shortcuts, all you get is the start menu. The user can create a desktop shortcut if they want to, but we can't do it for them. I think in theory having an app installer create a desktop shortcut was always frowned upon, but it became so ubiquitous so quickly after the desktop was introduced that nothing could ever really be done about it. Until now I guess.

Status: NEW → RESOLVED
Closed: 6 months ago
Flags: needinfo?(mhowell)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.