Closed Bug 1723298 Opened 6 months ago Closed 6 months ago

Perma Windows DevEdition toolkit/profile/xpcshell/test_select_profile_package_downgrade.js | - Should have seen the right startup reason. - "firstrun-created-default" == "firstrun-claimed-default" when Gecko 92 merges to Beta on 2021-08-09

Categories

(Firefox :: Installer, defect)

Firefox 92
defect

Tracking

()

VERIFIED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- unaffected
firefox90 --- unaffected
firefox91 --- unaffected
firefox92 + verified

People

(Reporter: dluca, Assigned: mhowell)

References

(Regression)

Details

(Keywords: regression)

Attachments

(1 file)

[Tracking Requested - why for this release]:

Central-as-beta-simulation:
https://treeherder.mozilla.org/jobs?repo=try&revision=ddf5d450f31d9f818689d5fe3e8d497add35bd1d&searchStr=windows%2C10%2Cx64%2Cwebrender%2Cdevedition%2Copt%2Cxpcshell%2Ctests%2Ctest-windows10-64-devedition-qr%2Fopt-xpcshell-e10s%2Cx2

Log:
https://treeherder.mozilla.org/logviewer?job_id=346993673&repo=try&lineNumber=5880

INFO -  TEST-START | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js
[task 2021-07-31T13:23:49.803Z] 13:23:49  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js | xpcshell return code: 0
[task 2021-07-31T13:23:49.803Z] 13:23:49     INFO -  TEST-INFO took 130ms
[task 2021-07-31T13:23:49.804Z] 13:23:49     INFO -  >>>>>>>
[task 2021-07-31T13:23:49.804Z] 13:23:49     INFO -  (xpcshell/head.js) | test MAIN run_test pending (1)
[task 2021-07-31T13:23:49.804Z] 13:23:49     INFO -  (xpcshell/head.js) | test run_next_test 0 pending (2)
[task 2021-07-31T13:23:49.804Z] 13:23:49     INFO -  (xpcshell/head.js) | test MAIN run_test finished (2)
[task 2021-07-31T13:23:49.804Z] 13:23:49     INFO -  running event loop
[task 2021-07-31T13:23:49.805Z] 13:23:49     INFO -  toolkit/profile/xpcshell/test_select_profile_package_downgrade.js | Starting
[task 2021-07-31T13:23:49.805Z] 13:23:49     INFO -  (xpcshell/head.js) | test pending (2)
[task 2021-07-31T13:23:49.805Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Start with last profile should match. - true == true
[task 2021-07-31T13:23:49.806Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should be the same number of profiles. - 1 == 1
[task 2021-07-31T13:23:49.806Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have the same name. - "default" == "default"
[task 2021-07-31T13:23:49.806Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have the same path. - "C:\\\\Users\\\\task_1627737024\\\\AppData\\\\Local\\\\Temp\\\\xpc-profile-gvehzh9x\\\\data\\\\default" == "C:\\\\Users\\\\task_1627737024\\\\AppData\\\\Local\\\\Temp\\\\xpc-profile-gvehzh9x\\\\data\\\\default"
[task 2021-07-31T13:23:49.806Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have seen the right profile selected. - null == null
[task 2021-07-31T13:23:49.807Z] 13:23:49     INFO -  (xpcshell/head.js) | test run_next_test 0 finished (2)
[task 2021-07-31T13:23:49.807Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have matched the root dir. - true == true
[task 2021-07-31T13:23:49.807Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have matched the local dir. - true == true
[task 2021-07-31T13:23:49.808Z] 13:23:49     INFO -  TEST-PASS | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have marked the profile as the current profile. - true == true
[task 2021-07-31T13:23:49.808Z] 13:23:49  WARNING -  TEST-UNEXPECTED-FAIL | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js |  - Should have seen the right startup reason. - "firstrun-created-default" == "firstrun-claimed-default"
[task 2021-07-31T13:23:49.808Z] 13:23:49     INFO -  Z:/task_1627737024/build/tests/xpcshell/tests/toolkit/profile/xpcshell/test_select_profile_package_downgrade.js:null:50
[task 2021-07-31T13:23:49.808Z] 13:23:49     INFO -  Z:\task_1627737024\build\tests\xpcshell\head.js:_do_main:240
[task 2021-07-31T13:23:49.809Z] 13:23:49     INFO -  Z:\task_1627737024\build\tests\xpcshell\head.js:_execute_test:597
[task 2021-07-31T13:23:49.809Z] 13:23:49     INFO -  -e:null:1
[task 2021-07-31T13:23:49.809Z] 13:23:49     INFO -  exiting test
[task 2021-07-31T13:23:49.809Z] 13:23:49     INFO -  Unexpected exception NS_ERROR_ABORT:
[task 2021-07-31T13:23:49.809Z] 13:23:49     INFO -  _abort_failed_test@Z:\task_1627737024\build\tests\xpcshell\head.js:860:20
[task 2021-07-31T13:23:49.810Z] 13:23:49     INFO -  do_report_result@Z:\task_1627737024\build\tests\xpcshell\head.js:961:5
[task 2021-07-31T13:23:49.810Z] 13:23:49     INFO -  Assert<@Z:\task_1627737024\build\tests\xpcshell\head.js:75:21
[task 2021-07-31T13:23:49.810Z] 13:23:49     INFO -  proto.report@resource://testing-common/Assert.jsm:228:10
[task 2021-07-31T13:23:49.810Z] 13:23:49     INFO -  equal@resource://testing-common/Assert.jsm:270:8
[task 2021-07-31T13:23:49.811Z] 13:23:49     INFO -  checkStartupReason@Z:/task_1627737024/build/tests/xpcshell/tests/toolkit/profile/xpcshell/head.js:597:12
[task 2021-07-31T13:23:49.811Z] 13:23:49     INFO -  @Z:/task_1627737024/build/tests/xpcshell/tests/toolkit/profile/xpcshell/test_select_profile_package_downgrade.js:50:21
[task 2021-07-31T13:23:49.811Z] 13:23:49     INFO -  _do_main@Z:\task_1627737024\build\tests\xpcshell\head.js:240:6
[task 2021-07-31T13:23:49.811Z] 13:23:49     INFO -  _execute_test@Z:\task_1627737024\build\tests\xpcshell\head.js:597:5
[task 2021-07-31T13:23:49.812Z] 13:23:49     INFO -  @-e:1:1
[task 2021-07-31T13:23:49.812Z] 13:23:49     INFO -  exiting test
[task 2021-07-31T13:23:49.812Z] 13:23:49     INFO -  <<<<<<<
[task 2021-07-31T13:23:49.824Z] 13:23:49     INFO -  TEST-START | devtools/server/tests/xpcshell/test_breakpoint-20.js
[task 2021-07-31T13:23:50.222Z] 13:23:50     INFO -  TEST-PASS | devtools/server/tests/xpcshell/test_breakpoint-20.js | took 399ms
[task 2021-07-31T13:23:50.236Z] 13:23:50     INFO -  TEST-START | devtools/server/tests/xpcshell/test_stepping-12.js
[task 2021-07-31T13:23:50.667Z] 13:23:50     INFO -  TEST-PASS | devtools/server/tests/xpcshell/test_stepping-12.js | took 431ms
[task 2021-07-31T13:23:50.737Z] 13:23:50     INFO -  TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_cookies.js
[task 2021-07-31T13:23:52.362Z] 13:23:52     INFO -  TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_cookies.js | took 1624ms
[task 2021-07-31T13:23:52.444Z] 13:23:52     INFO -  TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_download.js
[task 2021-07-31T13:23:53.913Z] 13:23:53     INFO -  TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_download.js | took 1468ms
[task 2021-07-31T13:23:53.984Z] 13:23:53     INFO -  TEST-START | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_misc.js
[task 2021-07-31T13:23:55.532Z] 13:23:55     INFO -  TEST-PASS | xpcshell-remote.ini:toolkit/components/extensions/test/xpcshell/test_ext_downloads_misc.js | took 1547ms
[task 2021-07-31T13:23:55.545Z] 13:23:55     INFO -  INFO | Result summary:
[task 2021-07-31T13:23:55.545Z] 13:23:55     INFO -  INFO | Passed: 1835
[task 2021-07-31T13:23:55.545Z] 13:23:55  WARNING -  INFO | Failed: 1
[task 2021-07-31T13:23:55.546Z] 13:23:55  WARNING -  One or more unittests failed.
[task 2021-07-31T13:23:55.546Z] 13:23:55     INFO -  INFO | Todo: 4
[task 2021-07-31T13:23:55.546Z] 13:23:55     INFO -  INFO | Retried: 11
[task 2021-07-31T13:23:55.546Z] 13:23:55     INFO -  SUITE-END | took 501s
[task 2021-07-31T13:23:55.547Z] 13:23:55     INFO -  Node moz-http2 server shutting down ...
[task 2021-07-31T13:23:55.549Z] 13:23:55     INFO -  http3Server server shutting down ...
[task 2021-07-31T13:23:55.710Z] 13:23:55    ERROR - Return code: 1

Molly: Can you please take a look at this bug? I think it was caused by Bug 1709969

Flags: needinfo?(mhowell)
Summary: TEST-UNEXPECTED-FAIL Perma | toolkit/profile/xpcshell/test_select_profile_package_downgrade.js | - Should have seen the right startup reason. - "firstrun-created-default" == "firstrun-claimed-default" when Gecko 92 merges to Beta on 2021-08-09 → Perma Windows DevEdition toolkit/profile/xpcshell/test_select_profile_package_downgrade.js | - Should have seen the right startup reason. - "firstrun-created-default" == "firstrun-claimed-default" when Gecko 92 merges to Beta on 2021-08-09

Yep, this was me. I didn't think about the default profile name being different on dev edition, so this test wasn't running the code path I expected.

Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Flags: needinfo?(mhowell)
Pushed by mhowell@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/a4bca433c8f7
Use the correct default profile name, since it's different for dev edition. r=mossop
Status: ASSIGNED → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
You need to log in before you can comment on or make changes to this bug.