Closed Bug 1723540 Opened 2 months ago Closed 2 months ago

Video output is green with SW-WR and VAAPI

Categories

(Core :: Audio/Video: Playback, defect, P3)

defect

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox92 --- fixed

People

(Reporter: rmader, Assigned: rmader)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

We currently allow VAAPI/DMABUF decoding with Webrender - also Software Webrender, even though it can't handle it and fails in https://searchfox.org/mozilla-central/source/gfx/wr/webrender/src/renderer/mod.rs#4179

Disable hardware video decoding when SW-WR is used.

We currently allow VAAPI/DMABUF decoding with Webrender - also Software
Webrender, even though it can't handle it and fails in
https://searchfox.org/mozilla-central/source/gfx/wr/webrender/src/renderer/mod.rs#4179

Pushed by robert.mader@posteo.de:
https://hg.mozilla.org/integration/autoland/rev/0dd09304ca66
Disable hardware video decoding when SW-WR is used. r=stransky

Getting this out of media triage queue -- though it looks like will be resolved soon by in flight patch. Please adjust values if needed.

Severity: -- → S3
Priority: -- → P1

(In reply to Bryce Seager van Dyk (:bryce) from comment #3)

Getting this out of media triage queue -- though it looks like will be resolved soon by in flight patch. Please adjust values if needed.

To trigger this issue, users need to enable at least two non-default settings (EGL backend, either through Wayland or X11-EGL, and media.ffmpeg.vaapi.enabled). Thus reducing the priority - it's probably still too high.

Priority: P1 → P3
Status: ASSIGNED → RESOLVED
Closed: 2 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
Duplicate of this bug: 1714839
You need to log in before you can comment on or make changes to this bug.