Closed Bug 1723741 Opened 6 months ago Closed 6 months ago

Recorded SVG image blobs don't display in taskbar

Categories

(Core :: ImageLib, defect, P3)

defect

Tracking

()

RESOLVED FIXED
92 Branch
Tracking Status
firefox-esr78 --- unaffected
firefox-esr91 --- disabled
firefox90 --- unaffected
firefox91 --- disabled
firefox92 --- fixed

People

(Reporter: aosmond, Assigned: aosmond)

References

(Blocks 1 open bug, Regression)

Details

(Keywords: regression)

Attachments

(1 file)

STR:

  1. Flip image.svg.blob-image to true
  2. Restart Firefox.
  3. Icons in the taskbar are missing.

This should only trigger when there is something other than an integer translation:

https://searchfox.org/mozilla-central/rev/4f05a46731c1f7f111ec7a41ce38a34594aa0d37/gfx/thebes/gfxUtils.cpp#531

But the only thing we do to the gfxContext transform is what should be an integer translation:

https://searchfox.org/mozilla-central/rev/4f05a46731c1f7f111ec7a41ce38a34594aa0d37/image/SourceSurfaceBlobImage.cpp#212

There are some floating point conversions here that might be getting in the way.

The signature differs from what I wrote:

https://searchfox.org/mozilla-central/rev/4f05a46731c1f7f111ec7a41ce38a34594aa0d37/gfx/thebes/gfxUtils.h#106

I guess I fixed the test case accidentally by setting the opacity to completely transparent, and shortcutting somewhere....

This occurred due to a signature mismatch with
gfxUtils::DrawPixelSnapped. A previous patch in bug 1712855 put the
wrong field in the opacity parameter. It implicitly converted a bool to
a float silently, causing the opacity to be 0.0.

Pushed by aosmond@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fa3677b2a1e5
Fix how SVG images in blob recordings would always be transparent. r=gfx-reviewers,jrmuizel
Status: NEW → RESOLVED
Closed: 6 months ago
Resolution: --- → FIXED
Target Milestone: --- → 92 Branch
QA Whiteboard: [qa-92b-p2]
You need to log in before you can comment on or make changes to this bug.