Basic Auth Dialog Box cannot be submitted or cancelled

VERIFIED WORKSFORME

Status

--
major
VERIFIED WORKSFORME
16 years ago
14 years ago

People

(Reporter: chrisb, Assigned: samir_bugzilla)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.1) Gecko/20020826

Occasionally (about once every 5 to 10 logins) a Basic Auth Dialog Boxes will
appear that cannot be submitted or cancelled. Clicking on the 'OK' or 'Cancel'
buttons does nothing. All other form buttons in other Mozilla browser windows
are disabled.

The only way to exit is using ctrl-alt-delete, which closes all Mozilla windows.

One possible clue: When a non-faulty Basic Auth Dialog Box appears, there is a
cursor flashing in the username field. If the Basic Auth Dialog Box is faulty, a
cursor does not initially appear in the username field.

Reproducible: Sometimes

Steps to Reproduce:
1.Go to a page that requires Basic Auth
2.If the username field has a cursor in it, click on cancel and keeping trying
again until a Basic Auth Box appears without a cursor in the username field.

Actual Results:  
The Basic Auth Dialog Box is non-functional. Text can be entered into the
username and password fields, but the the 'OK' and 'Cancel' buttons do not work.

Since the box cannot be closed, the only way to exit is to use ctrl-alt-delete,
which closes all instances of the Mozilla browser.

Expected Results:  
A working Basic Auth box should have appeared.

Comment 1

16 years ago
Chris, are yuo still experiencing this with a newer build?

Comment 2

16 years ago
resolving due to lack of response from reporter

please reopen if the bug persists in a new build
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

16 years ago
The bug still exists in versin 1.2, but occurs less often.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---

Comment 4

16 years ago
->Networking 

please bounce if wrong component
Assignee: asa → darin
Component: Browser-General → Networking: HTTP
QA Contact: asa → httpqa

Comment 5

16 years ago
-> prompt is not implemented in necko; over to XP Apps
Assignee: darin → sgehani
Component: Networking: HTTP → XP Apps
QA Contact: httpqa → paw
(Reporter)

Comment 6

16 years ago
The bug appears significantly less often in version 1.2.1.

The bug occurs once every few weeks now, rather than every few hours.

Comment 7

16 years ago
Chris, is the problem still there in 1.3?

Comment 8

16 years ago
Resolving due to lack of response from reporter

please reopen if the problem persists with Mozilla 1.4a or later
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → WORKSFORME

Comment 9

16 years ago
v
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.